Citra stuck on gray screen. (MacOS-Mojave)

Issue:
Enter a description of your issue here, in full detail.
Basically, when I load a game (Pokemon Sun) the citra screen turns grey, the music is still playing but I can’t see anything in the game. I did some research and most of the cases turning Hardware Shader off fixed it, in my case, when I turn it off it just doesn’t work.

System Information

  • Operating System:
    MacOS Mojave
  • CPU:
    Intel Core i5
  • GPU:
    GeForce GT 650M 512 MB (NVIDIA)
  • Citra Version (found in title bar):
    Citra Nightly 1674
  • Game: Pokemon Sun
  • Screenshot of Issue (include the full Citra window including titlebar):
    (Image at the link)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (11.8 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

Same error happens when attempting to play Pokemon X

MacOS didn’t like some of the recent changes made to Citra. So maybe your issue is related to that. To test that out, try this older Citra version:
Download citra-osx-20200707-bd7ee8c.tar.gz from https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1587
Extract it and then run the citra-qt executable found inside of the extracted folder.

Sorry, I’m new at this stuff, I don’t know how to download it. The site has 8 files, and I don’t really know which ones I should download. I tried to download “Source Code”, this .zip file, after I de-compressed it gave me some files but I can’t find the citra-qt application

I think I was pretty clear which one you should be downloading.

Nevermind I think I got it

Nope, still having the same issue…

Go to Citra>Preferences>Graphics>Advanced Tab and disable Hardware Shaders.

Already tried that before with the newer version, didn’t work, although it doesn’t work at the older version neither.

Hmmm, please try resizing your Citra window after the gray screen occurs. That sometimes works for some MacOS users for some reason.

THanks, it did work, but for some reason the game is rotated…?

Nervermind, fixed it, thanks for the help.