Citra sudden crash

Issue:
Enter a description of your issue here, in full detail.
Citra crashes without any reason when trying to load game shaders

System Information

  • Operating System: Windows 10 Home 64-bit
  • CPU: Intel Core i7 @ 1.80GHz (Kaby Lake-U/Y 14nm Technology)
  • GPU: 2047MB NVIDIA GeForce MX130
  • Citra Version (found in title bar): Citra Nightly 1621
  • Game: The Legend of Zelda - A Link Between Worlds
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (7.4 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1621 HEAD-df9e230
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-8565U CPU @ 1.80GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce MX130/PCIe/SSE2
GPU Driver Version                            417.88
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Hi, please try this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure… then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Thank you very much! It worked!