Citra suddenly won't open (Mac)

Issue:
Citra had been working fine but now suddenly will not run. Normally, I do not exit it and leave it running; but yesterday I closed it and today it attempts to boot and quits after 1 second. No changes should have occurred on my computer since then but I went ahead and tried restarting it. I also tried downloading and reinstalling (I could not figure out how to “uninstall” the previous Citra I had though and was also concerned I may lose saved files).

I tried unplugging my controller and disabling my antivirus as I saw mentioned on another post as well but that had no effect. I had also only had the canary version and tried installing the nightly version instead but neither of them will launch at all. All that happens is the icon pops up onto the toolbar for 1-2 seconds, then disappears, and then a little while late the notification that Citra quit unexpectedly comes up.

System Information

  • Operating System: Latest OS

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

I cannot figure out how to save the diagnostic file but here is what it says under the readme text; I am wondering if this part specifically may point toward the issue:

Failed to receive mach message. error: 0x10004006 ((ipc/rcv) port changed)

Full text:

Last login: Sat Nov 14 04:19:38 on ttys000

/Applications/Citra/canary/citra ; exit;

MacBook-Pro-9:~ Codar$ /Applications/Citra/canary/citra ; exit;

[ 0.010368] Frontend citra/citra.cpp:main:334: Failed to load ROM: No ROM specified

dynarmic: macOS MachHandler: Failed to receive mach message. error: 0x10004006 ((ipc/rcv) port changed)

logout

Saving session…

…copying shared history…

…saving history…truncating history files…

…completed.

[Process completed]

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Try use this older build: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1587

It seems macOS didn’t like this change which was added since 1588:

Thank you! I figured out how to uninstall Citra and am currently reinstalling it; if that doesn’t work I will give this a shot. I never had any problem running Citra, except for one setting I had to change after it began automatically crashing when loading games.

Reinstalling did not work. I downloaded the file in your link and extracted it but I am unsure how to use it since it has no installer. The “Citra” file shows up as a document.

Download citra-osx-20200707-bd7ee8c.tar.gz then extract it. Run \citra-qt.app\Contents\MacOS\citra-qt. You might need to use the terminal to open it.

And to do this, do I want any previous version of Citra uninstalled? Also, I apologize–I don’t know much about this stuff–what exactly do you mean by “use the terminal”?

Now the Citra-qt file shows up with the Citra logo but when I click to launch it, I get a prompt saying that it can’t be opened.

I am not sure if this is relevant but the exec files in the older build you linked me to are shown as documents rather than how they are shown in the current version’s folder. I tried running the old one with and without the current version installed and it still displays the error message. I also made sure my security preferences allow this type of application to be opened.


Open the terminal first then navigate to the folder where you extracted Citra. Start Citra by typing ./citra-qt.

This might help as well:

Thank you kindly for the information. I never realized terminal was something I could use on my computer.

Here is what happens when I do that

I currently have the latest version of citra reinstalled as well. Do I need to uninstall it or should this older one work whether I have the main one installed or not?

Type cd first before the location of the folder. You can type ./citra-qt after the terminal has pointed to the correct folder.

cd stands for change directory.

Maybe check the howtogeek link to make this more convenient.

I have been dragging and dropping the folder from its location like the link mentions. I typed cd, then dragged and dropped, and then typed ./citra-qt and pressed enter and it says “No such file or directory”

So, I deleted the file I downloaded with the older build on it and then redownloaded it. But instead of opening it with WinZip, I used the ArchiveUtility (which I don’t believe I had until I installed a software update just recently) and it opened and booted my game just fine. I have no idea what the issue was but I would like to thank you kindly for all your help! I appreciate it :slight_smile:

2 Likes