Citra terrible performance on AMD

Issue:
Hello, I almost have the same specs as my friend (he has got a nvidia card) who can run games smoothly by twaeking emulation speed, however, I can’t run any game at full speed, and the limiter change only change the limit, keeping the speed at the same (low) level.
In these last days I am trying to run Pokemon Sun at 100% and I’ve tried every setting, but Citra really can’t do it on my pc. I really don’t get why. Here are my specs:

System Information

  • Operating System: Win10 64bit
  • CPU: Amd Ryzen 2600
  • GPU: Amd rx590
  • Citra Version (found in title bar): Nightly 1714/Canary 1989
  • Game: Actually every game, but right now I’m mostly intrested in Pokemon Sun

Diagnostic Log
citra_log.txt (6.1 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

unfortunately Citra doesn’t like AMD much, hence why the performance is worse

as someone who got AMD Athlon Silver 3050U with Radeon Graphics, my graphics settings are:

  • set internal resolution to Native (400x240)
  • disabled linear filtering
  • no post-processing shader
  • no texture filter
  • enabled hardware renderer
  • enabled hardware shader (no accurate multiplication)
  • enabled shader JIT + Disk Shader Cache
  • disabled v-sync

and Pokemon Sun works great for me (99-100% speed, 30fps) :grinning:
might be worth saying that I use Nightly 1723, try these settings on this version and let me know if it works

Just tried this, but nothing changed. :slightly_frowning_face:
45% speed, 13 fps

Turn off Texture Dumping in the Graphics settings in Citra configuration. You ought to delete the dump folder which you can access by File -> Open Citra Folder as you probably have thousands of images there by now.

Try turn off Hardware Shader in the Advanced graphics settings in Citra configuration. It might provide a speed boost. If you want better performance (typically 3x) then you will need to dual boot Linux (e.g Ubuntu) as there are better OpenGL drivers there for Radeon.

Sorry for the inconvenience.