Citra Token not working & not refreshing

Issue:
Trying many times my Citra Token is not working, I have tried to set the username and token in the settings, but it refuses to verify, always showing the “X”, I assumed it just was an invalid key and something messed up so I tried to refresh the key but nothing happens, I have tried this on multiple devices and still no change in the Token. I have restarted both my browsers and Citra many times, and have even tried going into the qt-config.ini, but it still wont work.
-Yes, my account is verified
-Yes, I have tried to remove qt-config, I still get the error
///////////////EDIT////////////
[ 0.000000] Frontend citra_qt/main.cpp:CheckForUpdates:507: Unable to start check for updates
///////////EDIT OVER////
This is the only thing that shows in the log, not sure if it’s needed but this could allude to something.
System Information
I am running the Citra Cannary build (I assume)

Diagnostic Log
No logs, Token problem

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.