Citra touch screen not working

Hey everyone,

I just randomly noticed that my bottom screen isn’t working correctly, I haven’t had any issues with it before. Then today out of nowhere, it just isn’t working or it work but only at random times. I’ve had citra for a long time, so I’m not sure why this is sudeenly happening.

System Information

  • Operating System: Windows 10 Pro x64
  • CPU: AMD FX(fm)-6350 Six-Core Processor
  • GPU: NVIDIA GeForce GTX 1660 Ti
  • Citra Version (found in title bar): Canary 1485
  • Game: All Games

edit: I also downloaded the latest driver for my graphics card and did a clean install, and it still isn’t working correctly.

edit: here is the updated log after updating the graphics driver

citra_log.txt (312.4 KB)

System Information for Support

Client Version                                Canary 1485 HEAD-2aaef8a
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1660 Ti/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            436.02
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

System Information for Support

Client Version                                Canary 1485 HEAD-2aaef8a
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1660 Ti/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            436.02
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

System Information for Support

Client Version                                Canary 1485 HEAD-2aaef8a
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1660 Ti/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            436.02
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

System Information for Support

Client Version                                Canary 1485 HEAD-2aaef8a
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1660 Ti/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            436.30
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Sorry for the double post, but does anyone have any ideas? It just won’t work at all. It was perfectly fine like 2 days ago. Now it won’t let me click or when it does, it works sparingly.

Edit: I just messed around with the the screen sizes and it works in side by side mode but none of the other modes. However I need it in large screen mode for my layouts.

Apologies, there are some behind-the-scene changes to how layouts and visual screens are rendered (exciting, because aside from better accuracy, this can help lead towards the beginnings of screensplit, and easier custom layouts), but touchscreen was unfortunately recently broken as a result. The developer handling it is aware of this, and will be fixing it within a day or 2.

Thank you so much AuraOfTheDawn!

I was racking my brain about this all day yesterday, and then I opened nightly build and it was fine. So I thought it might have been due to the new update. I really appreciate you letting me know!