Citra unresponsive on launch

Issue:
Hi, I’m just trying to launch Citra and it doesn’t seem to respond. The window opens, but there is just a blank white screen. Soon after, it just says it’s not responding anymore. I’ve tried the nightly and canary builds and they both have the same outcome. I tried a manual download as well, and that didn’t work either. Can someone tell me what’s going on?

System Information

  • Operating System: Windows 11 Home 22H2
  • CPU: AMD Ryzen 7 4800H with Radeon Graphics 2.90 GHz
  • GPU: NVIDIA GeForce GT 1660 Ti
  • Citra Version (found in title bar): Canary 2643 and Nightly 2005
  • Game: Can’t even launch the application
  • Screenshot of Issue (include the full Citra window including titlebar): It’s just a blank white screen

Diagnostic Log

citra_log.txt (3.2 KB)

No game was booted in your log. If you are experiencing a crash then do not open citra again until after you posted the log as it gets purged when you reopen citra.
For more information, see How to Upload the Log File

The log file is incomplete. Make sure you follow the steps carefully:

  1. Open Citra, then go to File>Open Citra Folder (Citra>Open Citra Folder if on MacOS) and open up the log folder. Now keep that open in the background.
  2. Launch your game and encounter the problem; crash/slowdown/glitch and close Citra if it doesn’t do so by itself. Do not restart Citra as that will wipe the log of important information!
  3. Now upload the log file in this chat.

I can’t even launch a game, what do you want me to do?

In that case, try updating your iGPU drivers: https://www.amd.com/en/support/apu/amd-ryzen-processors/amd-ryzen-7-mobile-processors-radeon-graphics/amd-ryzen-7-4800h