Citra used to work on Mac, now it just gives me crash

Enter a description of
Citra (Vulkan Experimental) used to work just fine on my Mac air, but when I tried different versions to see if I could get access to multiplayer (no luck) then come back, now all it does is crash when I try and open a game. The game is Monster Hunter Three Ultimate, and I really want to play it again.

System Information

  • Operating System: macOS Monterey 12.2.1
  • CPU: dunno
  • GPU: dunno
  • Citra Version (found in title bar): experimental-vulkan-2-673e0df
  • Game: Monster Hunter Three Ultimate
  • Screenshot of Issue (include the full Citra window including titlebar):
    It just crashes I can’t really screenshot it.
    citra_log.txt (14.3 KB)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:

We aren’t giving support with the Vulkan builds atm. Please wait until it is in Citra Canary.

Just so you know, with nightly builds that work (Or used to, I guess.) , it just gives me a white screen and 0 fps.

Then upload a log file for those?

citra_log.txt (1.6 MB)

Just so you know, these never worked in the first place, I don’t think…

Ah, you’re on an M1/M2 MacOS device. You’ll need to wait until Vulkan hits the Canary builds.