Citra VERY slow (but it wasn't before)

Issue:
The emulator is VERY slow when a few versions ago it was buttery smooth. I could play Super Mario 3D Land full speed (on the VERY same PC) and now its hardly playable. Same goes with other games such as zeldas (OOT and MM).

System Information

  • Operating System: Linux MInt 19
  • CPU: Ryzen 3 2200G
  • GPU: Nvidia Quadro K2200 (with proprietary driver v 440).
  • Citra Version (found in title bar): Canary 1570
  • Game: Mario 3D Land, Zelda OOT 3D and others.
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Couldn’t find log. It says Windows Only. I’m running GNU/Linux.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Sure. Let me check the guide. Thanks!

citra_log.txt (38.0 KB)

System Information for Support

Client Version                                Canary 1570 HEAD-3d374d79d
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               Quadro K2200/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            440.64.00
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • LLE Audio is designed for debugging purposes. Using this option will slow down your game. Try changing to HLE audio.

Damn! it was the audio thing. I don’t rember having changed it!

Thanks a lot!