Citra was running well and then it suddenly got slow

#1

Issue:
Enter a description of your issue here, in full detail.

System Information

  • Operating System: MacOS High Sierra 10.13.6
  • CPU: 2.5GHz Intel Core i5
  • GPU: AMD Radeon HD 6750M 512
  • Citra Version (found in title bar): Nightly Build 4702555
  • Game: Pokemon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296citra_log.txt (27.6 KB)
citra_log.txt (45.8 KB)

I was running Citra for over a month now, and it ran pretty smoothly, outside of a few very rare crashes (sometimes I played it for 10 hours straight and never got a single crash), it was running between 88 to 100% almost all the time, it really was perfect to play, 30 FPS not a problem at all. Then yesterday, it suddenly started to run slow, when I launch it, the speed is between 90 and 100%, but when I log into the actual game, it suddenly drops by half and stays at 45 to 55%, and it doesnt come back to normal anymore. I tried multiple settings, multiple builds including canary, even scanned my mac for malware, got them all out, and the problem still persists. I played 5 different pokemon playthroughs and never had a problem, and then suddenly this unfixable problem happened. Anyone got an idea how to fix this?

Low FPS sudently
Frame Drop Random But Constant
#2

I did not find anything wrong in your log file. Please wait for a moderator to assist.

#3

nothing wrong, but the speed suddenly changed, I dont know how to fix it.

#4

You can try disabling the frame limit.

#5

I tried that already, I kinda tried everyhing that I could think of, it always comes back to 45 to 55% speed, its a huge drop all the sudden and it doesnt go back to normal

#6

Have you tried any older Canary builds?

#7

I did, I actually had sucess with a nightly build, but for some unknown reason, it just stopped working like it was before, and I dont know why, I know my mac can handle it since it was running for a month, so I really dont know what to do

#8

something really weird about it too is that for example, when I use my pc box system to look at my pokemon, the speed goes back to normal, also happens when I use Charizard to fly, but as soon as I get to a walking place after the flying animation, the speed drops again

#9

Have you tried turning hardware shader off?

1 Like
#10

this is silly but doesn’t this PR disables ‘Enable Hardware Shader’ on any macos config? i mean, there is a correlation for intel and mac os config threads here but i did a quick search to confirm i didn’t find any tag search with ‘mac os x Nvidia | AMD’ (or at least substantial) threads inferring this as being only a “mac os x issue”.

OP should enable ‘Enable Hardware Shader’ before opening citra using the latest canary version.

1 Like
#11

I did, didnt work as well, its really weird how it went from working perfectly to basically unplayable

#12

Tried all the nightly and canary versions I could, also tried all the configs I could, it just doesnt fix the problem, and it should work on a nightly build anyway since I was playing on it for over a month, it just doesnt make any sense why the performance went down like that and it doesnt come back to normal anymore

#13

bisect your way through older citra builds to find which build this performance issue began to happen, start with a build about the time you are sure that it worked as before, for example, say about two months ago, nightly 750.

You can do a guesstimate by using the nightly link above and append a build number to find a build at a certain point in time. if for example nightly 750 works for you, go half way between it and the current (nightly 909) which is 829, do that until you find in which build your issue began to occur.

#14

I’ll try that, I dont know if it will help, but given the circunstances, I gotta try everything

#15

Are you on a laptop maybe? Have you tried switching to an integrated graphic card? A recent update reset my switchable graphics settings back to “high performance” (so it’d use my amd card) from “power saving” (which uses my integrated intel card)

From the FAQ:

Also, it has been reported that using the integrated Intel GPU on laptops has shown major performance increased in emulation speed. Only some games will benefit from it. This also applies for other emulators as well. Feel free to test both integrated and dedicated GPU to see which one gives you the best performance.

1 Like
#16

no, I’m using an Imac, standard computer, I really cant make any sense of this, I even cleaned my mac so it would run at max speed, but still the same problem persists… Given the fact that I already had a good experience with Citra before, there’s really not a logical explanation for this, at least I cant think of one, it just slowed down and doesnt come back to normal

#17

by the way, I tried that now, and it didnt work, thanks for the idea though

#18

if you didn’t find a single build, going through the first one you ever used to the most current build, than that probably means that something on your computer changed rather than citra…
anyway, look into your web browser history, you may find when you first used citra or which version you’ve downloaded in the past.

1 Like
#19

I didnt change a thing, and again, I tried to backtrack and left my mac as fast as it could, much faster than it was when I was running citra well the first time, thats why I say it doesnt make any sense

#20

Download any nightly build from a time where you remember running well, extract in a folder and inside of it create a folder named user. open the folder:
/Users/your_username/.local/share/citra-emu/
and copy the folder nand to the user folder you’ve just created.

this is now a copy of citra in portable mode, without any previous configuration. now enable ‘Enable Hardware Shader’ and open your game rom. start a fresh save game. see if your framerate is ok.

btw, this won’t interfere with your current citra config.