Citra with Steam Link

Firstly, thanks for the amazing emulator, it is flawless and helps me play my favourite games in a way I never dreamed of :slight_smile:

So, I’m trying to use the emulator on my Steam Link. After playing around with it for a long time I finally managed to get the game to open in Steam Link through the Emulator. I thought that everything would finally be working OK until I couldn’t get my controller (Dualshock 4) to work with the emulator.

I managed to get my controller to work with Steam’s Big Picture mode on my PC after editing the config.ini file, and thought this would solve my problem. But as soon as I use my Steam Link on my TV, it doesn’t recognize it. I’ve messed around with all the settings in my Steam Link and it won’t fix my problem. The only thing I can think of is that I need to use a different configuration for a controller in the config.ini file to get it to work with the Steam Link.

Anyone have any ideas? It’s the last hurdle!

I’m assuming that Steam Link will create a virtual gamepad.
If that’s the case you have to increase the joystick index in the config file to 1, maybe 2 or 3.
(Assuming another original gamepad is still plugged in)

If that doesn’t work I’m clueless though.


Technically Citra just uses SDL2 for input and addresses controllers by index starting at 0.
So aimed with that information you could be asking for Support at Valve / Steam probably.

(Or look for information how Controllers via network are technically implemented in Steam Link)

I increased the joystick index and it still doesn’t work. What confuses me the most is that on my PC it will work in Big Picture mode, and the Steam Link as far as I know uses exactly the same settings as Big Picture mode.

I went on Dolphin as it tells you what controller you are using and on the Steam Link it says I’m using Xinput/0/Gamepad. I’ve tried the Xinput config settings on Citra and still no good.

There must be a way to fix this. The games would look so good on my big TV :frowning:

I managed to get this working briefly, very briefly. I turned off the DS4 settings in the SL and it let me play with the D-pad and only the X button on the controller. It let me change the input settings for only the A button (the X button on the DS4) on the emulator and it was assigning that button as the Return key on a keyboard. I haven’t spent a lot of time trying to figure it out since this and I have already got a Steam controller on its way so I’ll probably wait for that to see if it will work.

It definitely shouldnt be this complicated and I’m confusing even myself in typing this post.

The configure dialog / graphical user interface (GUI) does not work with controllers. Gamepads / controllers must be configured through the qt-config.ini still.

See the related “Tutorial” topic.

If your gamepad can be mapped through the configure dialog then something emulates a keyboard, which is not correct and will cause trouble with analogs (which can not be simulated by a keyboard properly).