Citra won't boot on my non-M1 mac

Issue:
I’ve never used Citra before, but went on your site, downloaded the newest Nightly build for OSX, and tried to run citra-qt. I get an error saying “citra-qt cannot be opened because of a problem. Check with the developer to make sure citra-qt works with this version of macOS…”

System Information

  • Operating System: BigSur 11.2.3
  • CPU: 1.8 GHz Dual-Core Intel Core i5
  • GPU: Intel HD Graphics 6000 1536 MB
  • Citra Version (found in title bar): a5d01c0, from three days ago. It won’t boot, so I can’t actually read the title bar.
  • Game: N/A
  • Screenshot of Issue (include the full Citra window including titlebar): Note that Citra will not actually boot, so I cannot provide a screenshot of the window itself.
    249018120_1481349315598187_4621425500996250021_n

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I tried to search for a copy of citra_log.txt in Finder, but couldn’t find anything.

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Update: I plugged the information into Terminal exactly as stated, but nothing printed. I then used Go to Folder to navigate to /usr/local/shared/, but ~/citra-emu/ does not exist.

What type of mac do you have? Apple released Mac OS Monterey a few days ago. Maybe try updating

It’s a 2017 MacBook Air. I didn’t realize a new OS was released recently.

Please use Citra Canary for now. The issue should’ve been fixed there already.

Canary seems to work just fine, thanks! I am getting that error where I can’t see the emulation unless I resize the window, but that’s not a problem at all. I’m just happy it works.