Citra won't launch at all

I’ve downloaded both Citra Canary and Nightly, whenever I launch Citra.exe it flashes a dos box at me then crashes. I tried Citra-qt.exe but that won’t play any roms.

System Information

  • Operating System: Windows 10

  • CPU: Intel i7-6700K 4.00GHZ

  • GPU: GTX 1070

  • Citra Version (found in title bar): 670cee1 / fc62da5

  • Citra log is empty.

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

are you using the installer or manual download? could you download it again?

I tried both, and I got the same result. Flash of a dox box then nothing, no matter how many times i open it.

Citra-qt.exe is the only one you need to run. Please provide more information about why “it won’t play any roms”.

When I try to load a DAT file into Citra-qt.exe it freezes and I have to force close it, each time

Citra doesn’t load .DAT files, are your games in .DAT files?
your need to dump them in something like the .3ds format.