Citra wont open

Issue:
Citra wont open for me. Ive gone through a bunch of other threads trying to fix it and none for them worked. I tried both the installer and manual file and it just wont open, if i try to open the citra-qt I will see the icon pop up on my taskbar for a fraction of a second. I tried disabling the firewall also tried using the management tool and have restarted my pc and still wont open.

System Information

  • Operating System: Windows 10
  • CPU: Intel® Core™ i7-8700k CPU @3.70Ghz
  • GPU: NVIDIA GeForce GTX 1050Ti
  • Citra Version (found in title bar): Build a13a230
  • Game: None wont open so cant select game
  • Screenshot of Issue (include the full Citra window including titlebar):
    I dont have anything to screenshot when I try to open it no window apears

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
<citra_log.txt (98 Bytes) >

Open winver (just do a simple search near Start or press Windows Key+R and type that in the box).

image

Take a screenshot of it.

image

Yeah there have been reports that 1909 version has issues, you need to update to at least 2004. Try using Windows Update (Start -> Settings -> Update & Security -> Windows Update).