Citra's drop in fps when disabling hardware shaders, but crashing with hardware shaders on

Issue: Citra crashing or not having enough FPS
Whenever I’m opening citra, with hardware shader on, citra runs perfectly fine. But it crashes almost instantly. I tried turning hardware shader off, that worked, no more crashing, but the fps is around 15-20, and I cannot play citra with that,

System Information

  • Operating System: MacOs Big Sur
  • CPU: 1,4 GHz Dual-Core Intel Core i5
  • GPU: Intel HD Graphics 5000 1536 MB
  • Citra Version (found in title bar): Citra 2005.
  • Game: Pokemon Ultra sun.
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log

citra_log.txt (520.7 KB)

Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:

https://community.citra-emu.org/t/how-to-upload-the-log-file/296

1 Like

System Information for Support

Client Version                                Nightly 1588 HEAD-f4e727c
Operating System                              macOS 10.15
CPU                                           Intel(R) Core(TM) i7-8750H CPU @ 2.20GHz
Graphics API                                  OpenGL 4.1
Graphics Renderer                             AMD Radeon Pro 555X OpenGL Engine
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Please test whether this issue also occurs on the latest Canary version.

canary 2005 is the latest one, However, I uninstalled citra, then reinstalled the latest canary i could find. which was one day ago. Still crashes. Also, i’ve tried the latest nightly too, didn’t work either. But Canary seems to give me longer time before crash, but it’s still annoying how it crashes every 5 minutes.

Any help? I cant seem to make it work

Please try running your game without the use of any Save States and see if the problem remains. If it does, please upload another log file.

how do i run it without a save state?

should i google it orr? im not really sure what a save state is

Save States are Citra’s built in saving method, found under the Emulation tab. What I’m asking you to do is to not use those, but instead load your in-game save file instead.

oh yeah, i don’t have any save states. so i’m not using any.

The game’s fps works perfectly fine with hardware shader, but crashes almost 2 minutes into the game. but when i turn it off, it doesn’t crash but the fps is really bad, maybe the problem is the hardware shader system? im not really sure

Taken directly from your log file:


That line only shows up when loading a save state. So that means you either uploaded a log file that you downloaded from somewhere else instead of generating one yourself, or you’re wrong. Please double check.


i used my own log file, and as you can see here, i have no load states.

Then please upload another log file.

Hey, I have the exact same problem as you, and I’m using a mac as well, have you found any solution?

Please upload a log file here.

1 Like

When I disable hardware shaders the game doesn’t crash but it drops in fps. Log:
citra_log.txt (57.1 KB)

System Information for Support

Client Version                               Nightly 1766   HEAD-a6e7a81
Operating System                             macOS 11.6
CPU                                          Intel(R) Core(TM) i7-4578U CPU @ 3.00GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.1
Graphics Renderer                            Intel Iris OpenGL Engine
GPU Driver Version                           ?
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

I did not find anything wrong in your log file. Please wait for a human moderator to assist.

@autumnburra could you find any solution to my problem? I need help please.