Citra's Web Verification Error

I’ve been having trouble all night with this!
Lately, I’ve been enjoying Animal Crossing: New Leaf quite a lot on my free time, and decided it would be a nice adventure to find a way to visit someone else’s town. After some online research, and signing into citra’s community, I tried logging in the citra emulator to use rooms, but found myself stuck!

No matter how many times I tried, or how correctly I typed, the same error kept coming up!
“Verification failed. Check that you have entered your username and token correctly, and that your internet connection is working.”

I did, but this lead nowhere as everything was correct and in place.
Checking the logs, I saw that it had an odd message, but I don’t understand much of coding…
Here is said log:
“[ 0.000000] Common.Filesystem common/file_util.cpp:GetUserPath:693: Using the local user directory
[ 1.811846] Frontend citra_qt/main.cpp:CheckForUpdates:507: Unable to start check for updates
[ 14.124484] WebService web_service/web_backend.cpp:operator():181: GET to https://services.citra-emu.org/api/profile returned error status code: 404
[ 92.999985] WebService web_service/web_backend.cpp:operator():181: GET to https://services.citra-emu.org/api/profile returned error status code: 404”

I hope it can be of help! Contact me if anything else is needed, or if I have misplaced or did something wrong. Thank you in advance!

Close citra and open this folder: C:\Users\%username%\AppData\Roaming\Citra\config, delete the ‘qt-config.ini’ file in it (this will reset your citra settings), launch citra and input your username (forum username), your token, then click on ‘Verify’.

1 Like

Thank you for your reply!

Unfortunately, it still gives the same error… And the logs only say something went wrong with the website, nothing else.

Still, I appreciate your help! Thank you!

-I have also checked that when pressing the “Sign Up” button inside the “Web” definitions leads me to a site wich only reads an error message:

https://services.citra-emu.org/
404 page not found

There may be a problem with the service. by the way what citra build are you using?

I see…

The build I am using is the Canary Build (HEAD-bae4b4b).
It could be outdated.
(Tell me if I have not written the proper information, sorry in advance!)

Very much so, download the latest build.

It seems the install directory contains “Non-ASCII” files, but I don’t seem to understand what that means…

Basically means that the folder path to the installation directory, e.g: C:\Users\%username%\AppData\Roaming\, contains characters (letters) that are not ascii. try installing in a folder like C:\Citra or simply download citra manually, just click on manual download on citra’s download page.