Colour problem in pokemon sun

my pc is facing some colour issues with pokemon sun . i am getting 57 fps but the colour problem is there. it is okay with other games but in pokemon sun it specially happens.

System Information

  • Operating System: windows 7
  • CPU: i3-4005U
  • GPU: intel hd graphics 4400
  • Citra Version (found in title bar): 1719
  • Game: pokemon sun
  • Screenshot of Issue (include the full Citra window including titlebar):

    citra_log.txt (79.1 KB)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:

System Information for Support

Client Version                                Nightly 1719 HEAD-dfd7926
Operating System                              Windows 7 SP 1 (6.1)
CPU                                           Intel(R) Core(TM) i3-4005U CPU @ 1.70GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4400
GPU Driver Version                  
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Downloads for Graphics
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

the latest gpu is not compatiable with my cpu what should i do

I’ll just respond here for both your touch screen issues and your graphical issues then. You’ve opened up multiple topics for these things in quick succession. Please open only one topic for an issue and stick to it in the future.

As for your problem:
You appear to have changed a bunch of your settings to things that you don’t need as well as some that actually make your problem worse. Since there are this many, we’ll solve that later. First we’ll solve the cause of your problems: Your GPU drivers:

^ This GPU driver is out of date. To update, download (direct link) from Download Intel® Graphics Driver for Windows* [15.40]

Then follow this guide to install it:

Now we can fix the issues with your settings. We can fix this relatively easily though. Start up Citra, then go to Emulation>Configuration>General and press the Reset All Settings button.

Start Citra back up again and go to Emulation>Configuration>Graphics>Advanced Tab and disable Accurate Multiplication. Your GPU in particular has issues with this setting.

If the problem continues, upload another log file.

thanksman you solved it