Command line Citra can't find my config file

#1

Issue:

Citra-QT uses my configuration just fine, which is located at ~/.config/citra-emu/qt-config.ini. As a test I turned off CPU-JIT. When I run Citra using the command line bin, it doesn’t use the config and seems to revert to a default one, as you can see in the log the CPU-JIT is enabled again. It also doesn’t use my control config.

Can I put a symlink somewhere to my qt-config file so that the command line citra can find it too? My user dir is at ~/.local/share/citra-emu.

I’ve tried to find the answer myself but unfortunately I couldn’t find it. I’d appreciate any help :slight_smile:

edit: oh yes, I should mention I installed Citra using the regular download on the site, so it’s in /Applications/Citra/nightly.

System Information

  • Operating System: Mac OS X 10.14.4
  • CPU: 2,2 GHz Intel Core i7
  • GPU: Intel HD Graphics 6000 1536 MB
  • Citra Version (found in title bar): Citra HEAD 49f6f11
  • Game: homebrew

Diagnostic Log
citra_log.txt (7.2 KB)

#2

System Information for Support

OpenGL Vendor                                 Intel Inc.
OpenGL Renderer                               Intel(R) HD Graphics 6000
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
#3

System Information for Support

OpenGL Vendor                                 Intel Inc.
OpenGL Renderer                               Intel(R) HD Graphics 6000
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
#4

are you running the citra-qt or just citra?

#5

Just citra. I’ve started doing 3DS development so I was testing simply by invoking citra myfile.3dsx.

It does actually work when I run the citra-qt binary instead! Thanks for letting me know. Still, I’d be curious how I can customize the options for the regular citra binary.

#6

edit the ‘sdl-config.ini’ file instead, its in the same folder and the ‘qt-config.ini’ file.

#7

Sorry for replying so late. This thread slipped my mind for a few days… :upside_down_face:

Thanks for letting me know that sdl-config.ini is the right file to edit. Unfortunately I’ve had mixed results with it. I couldn’t just copy over my QT settings, it seems. For example, the control settings are apparently parsed differently, since button_a="code:70,engine:keyboard" choked on keyboard", believing the quotation mark to be part of the engine name. I got the log to stop complaining after I removed the quotation marks, but then the keys still wouldn’t work.

I’ve attached the log and the settings I was using for sdl2-config.ini.

log.txt (10.8 KB)
sdl2-config.ini (19.1 KB)

But it might not be a problem because I’ve just switched to using citra-qt which does work fine. I guess the controls might be parsed differently because the regular citra bin doesn’t have QT?

#8

System Information for Support

OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               AMD Radeon RX Vega 56 OpenGL Engine
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
Enable Vsync                                  null
LLE Audio Emulation Enabled                   null
System Region                                 [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
#9

Yes, i’m also unable to customize the controls for the sdl frontend, you can submit this issue here.