Config File problems with Command Line Citra

Issue:
I’m am running citra from a frontend per command line and understand that citra.exe (as opposed to citra-qt.exe) is the correct app to choose. But how can I configure citra.exe?

  • I understand that \appdata…\config\qt-config.ini is used in citra-qt.exe
  • I tried \appdata…\config\sdl2-config.ini but with no luck

Is sdl2-config.ini the correct config file for citra.exe?
If yes, how should I enter input mappings (c&p’d them from citra-qt.exe but they don’t work)?

Thanks for helping me out!

System Information

  • Operating System: win10 home 1903
  • CPU: intel i7-5500u @2.40 GHz
  • GPU:
  • Citra Version (found in title bar):nightly 1452
  • Game: not game specific
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296
citra_log.txt (92.8 KB)

System Information for Support

OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce 940M/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            385.69
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

After some more tinkering I can confirm sdl2-config.ini to be the correct config file.
However, my input mappings do not work. I input them as

button_a=“engine:keyboard,code:65”
button_b=“engine:keyboard,code:83”

for example. What did I do wrong?

Thanks for any suggestions.