Congigure controller with sdl2-config.ini

Issue:
I want to use Citra via an emulator frontend (GameEx), so I need to run citra.exe instead of citra-qt.exe (otherwise the gui gets in the way of the frontend). This works fine with only one problem: I cant seem to configure my controller that way. I have configured my gamepad with citra-qt and it works as intended. I tried to change my sdl2-config,ini, since I understand that’s what citra.exe uses it for its configuration. However it looks like I am doing something wrong, because I cant get my gamepad to work with citra.exe.

System Information

  • Operating System: Windows !0 home
  • CPU: Intel Core i7
  • GPU: Geforce RTX 2060
  • Citra Version (found in title bar): 1372

Changed lines in sdl2-config.ini:

button_a="engine:sdl,joystick:0,button:3"
button_b="engine:sdl,joystick:0,button:2"
button_x="engine:sdl,joystick:0,button:1"
button_y="engine:sdl,joystick:0,button:0"
button_up="engine:sdl,joystick:0,hat:0,direction:up"
button_down="engine:sdl,joystick:0,hat:0,direction:down"
button_left="engine:sdl,joystick:0,hat:0,direction:left"
button_right="engine:sdl,joystick:0,hat:0,direction:right"
button_l="engine:sdl,joystick:0,button:6"
button_r="engine:sdl,joystick:0,button:7"
button_start="engine:sdl,joystick:0,button:9"
button_select="engine:sdl,joystick:0,button:8"
button_zl="engine:sdl,joystick:0,button:4,threshold:-0.8,direction:+"
button_zr="engine:sdl,joystick:0,button:5,threshold:-0.8,direction:+"
button_home="engine:keyboard,code:66"

circle_pad="axis_x:0,engine:sdl,joystick:0,axis_y:1"
c_stick="axis_x:3,engine:sdl,joystick:0,axis_y:2"

I hope anyone can help me with advice on how to get my controller working properly with citra.exe

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

citra_log.txt (7.6 KB)

System Information for Support

Client Version                                Nightly 1372 HEAD-35690e3
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

OK bot, that didnt work, any human can help me with this problem?