Connecting to the Internet. Please Wait A moment Issue..Really NEED HELP

Im trying to trade while in a Citra Room. However, whenever i try to connect to the wifi using pss, it saves the game then gets stuck on Connecting to the Internet, please wait a moment.

System Information

  • Operating System: Windows 10
  • CPU: i3 720U
  • GPU:
  • Citra Version (found in title bar):
    Citra Canary 1704
  • Game: Pokemon Omega Ruby
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
citra_log.txt (3.1 MB)

System Information for Support

Client Version                                Canary 1704 HEAD-d6f4c63
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 620
OpenGL Version                                3.3.0
GPU Driver Version                  
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Make sure you are choosing the game’s local communication and not “internet” because Citra cannot connect to Nintendo’s servers.

How do i do that? Choose the games local communication?

Nevermind, I got it, Thanks a Lot for your help

what do you mean by dragging and dropping

It means holding the left mouse button on the file and drag it over the reply window then release.

Please help, I am stuck on this loading screen for hours. I tried reopening the Citra and loading my saved progress and its not working I tried to get rid of it and continue my game by pressing every single button possible. PLEASE i dont want my progress to be lost…

You cannot get out of that state, you will need to restart the game and load normally in-game (not save state). I hope you did not only use save states to save your game.

but what about my progress?
it will be all lost!?

OOH my it just got ok itself and i think is now connected to internet…whatever it worked out!!! YAYYYAYA

1 Like

Make sure you save often (normally in-game). Maybe you got lucky this time :stuck_out_tongue:

1 Like

I am too dumb to play games like this!!! …So i fckkkkkn messed up again and instead of clicking load i clicked SAVE!! when the game was starting so i lost my progress but can i somehow get it back PLEAAASEE??
13 yr olds and 10 yr old kids be looking at me like: Wth so dumb LOL

please help T_T …I am not gonna become a BOOMER aaaa

if possible i will give you my file with all the data i had and u can delete my latest save from it like i never did it …so will it go back to where i was with my pokemons?
…oh uh if you can help me by contacting on another contact (because this citra website dosent allow me to upload that file) or maybe you dont even need it to fix my issue.

If you do not have a normal save and only a save state which you accidentally overwrote there is no way to get it back unless you made a manual backup beforehand.

You have now learnt the hard way that save states can be “dangerous” and backing up your save files is important.

You will need to start over, sorry. Unless someone else is willing to give their save file to you.

oh…cool…thanks anyways drinks clorox it was nice to play pokemon I WANT TO play more but i guess i will go and try my luck on roblox loomian legacy!!

nice to meet you tywald, maybe if i ever will use citra again than it means i prolly wanna play and die losing my progress of pokemon sun and moon

somehow my progress is saved even tho i didnt use load state…THANK GOD i got “LUCKY” again

The same way you do it on your 3DS, simply start the game and get past the title screen and you will see the Continue screen. Basically just press “A” a few times :slight_smile:

“load states” is loading your “save state” :stuck_out_tongue: