Controller config not saved

Issue:

Hi, like others in the past my controller settings are not being saved after I set them. In the screenshot you can see my controller IS detected, afterwards it changes back to default keys.

System Information

  • Operating System: Linux Mint 20.2 Cinnamon
  • CPU: Intel© Pentium© Silver N5000 CPU @ 1.10GHz × 4
  • GPU: Intel Corporation UHD Graphics 605
  • Citra Version (found in title bar): Nightly 1715
  • Game: 7th Dragon III Code: VFD
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
citra_log.txt (5.5 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Are you using your controller wirelessly? If so, try using it with a wire and see if the issue remains (make a new profile for when you connect your controller via wire first though).

Thanks for the response. No, it’s a wired USB controller.

Then I’m out of ideas. I’m not really familiar with Linux myself. Maybe someone else can chip in on this to cover for my ignorance. Apologies.

No worries. I have a dual set-up, so tomorrow I’ll install Citrus on Windows 10 and test with the same hardware on a different OS.

I installed Citra on Windows 10, same computer and same controller. When I opened the configuration window I instantly saw the problem: there was an OK button that I cannot see under Linux.

I say ‘cannot see’ rather than ‘not there’ because it may be there but the window is too big and therefore probably under the taskbar (as can been seen on the screenshot in my OP).

I can place my mouse near the side edges of the configuration window to resize it (wider/more narrow) but although my mouse pointer changes to signify the same should be possible from the top it is actually impossible to resize top to bottom, ie. nothing happens. Obviously I can’t resize from the bottom upwards because the window is under the taskbar. I don’t think the fix for this should be Linux users messing with their taskbar settings.

Of course, the OK button may not be there at all, I have no idea.

Yes I can use Citra on Windows but that’s not a real solution and it’s not good for Citra, as the whole point for me and increasing numbers of other users is to get away from using modern iterations of Windows operating system for numerous reasons.

I have a feeling there is some setting that is causing the problem because I was able to change to the dark UI option previously. It seems I cannot change much in the configuration now because nothing is applied.

I suppose I could try to uninstall and reinstall to see if I can get back to default configuration settings, based on the above information, but since the above is conjecture for now I’ll wait until I get any feedback here.


[Edit]

I found the cause and a temporary working solution for Linux users!

I noticed on the General tab of the configuration window a button to ‘Reset all settings’ so I pressed it and it went back to the light UI theme plus I could suddenly see the OK button!
I then set up my controller, hit OK and tested in-game and the controller works as normal! I then went back to the config window and switched to the dark UI again, hit OK and lost the OK button again. Rather than resetting, I left it as the dark UI and returned into the game to test the controller and it was still working!

Therefore, under Linux, if you switch to the dark UI (maybe others) you lose the ability to confirm setting changes. So just set up your controller first, then set your UI, and you’re good to go.

Seems like this is a bug in the UI under Linux.

Thanks for looking into this! I’ll pass this along to the devs.

For reference, how did you install Citra? Through flathub or by building it yourself?

Through the Linux Mint Software Manager.