Controller Doesn't Work

Issue:
After looking at this controller configurations post (Temporary: Controller Configurations for Citra), i have found qt-config.ini but every time I edit something to try to configure my controls and open Citra, the controls don’t do anything (because i don’t have much of a clue to what I’m doing) and some text in the [Controls] section resets to the image below. I want to use a NS Pro Controller and I found the code that should configure the code but it didn’t work the couple times I tested it. (the configure code seems to be as should be for Pro Controller though)

System Information

  • Operating System: MacOS High Sierra
  • CPU: 2.7 GHz Intel Core i5
  • GPU: Intel Iris Graphics 6100 1536 MB
  • Citra Version: Nightly 1587
  • Game: Pokemon Ultra Sun

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

As the topic you linked states later on, those steps are completely out of date now as you can simply map your controller in Citra>Preferences>Controls.

Ok. Thanks for for that info. I’m in the Controls section and my controller still doesn’t work despite being on the correct settings. Every time I try to change the settings my computer won’t pick up my controller inputs, and immediately changes it to Button 1, Button 0, Axis +3, Axis -1. My NS Pro Controller is very much connected to the computer via the cord I got it with. Should I reinstall Citra because I did probably tamper with qt-config.ini?

Actually I just found something that ca connect NS Pro Controller to a bunch of stuff including Citra. I’m also reinstalling Citra

You should try deleting your qt-config.ini file. Citra should create a new one on launch. See if that allows you to map your controller.

Thanks again. The thing i found was only for windows so forget what i said earlier

Ok so tried that. It definitely did something but when i tried making a new profile for my pro controller it did the axis +3 and axis -1 thing immediately before I could press anything
Screen Shot 2021-04-24 at 10.57.25 AM

Are you mapping them manually or are you using the auto-map feature?

I don’t know what those are. Can you explain? Or just tell me where it can be found.

Oh I think I get it. Yeah I’m doing it manually as I’m clicking it then it changes to Axis +3 and stuff.

Does this happen with every button you’re trying to map? If so, your controller might be at fault here → it might have a problem where your joysticks are continuously registering as ‘‘being moved’’, causing the axis to immediately get mapped to the buttons as you press to map them. This is generally the case with older controllers.

That most likely the reason as my controller has drifted before, but it didn’t happen this time. It kept on saying [press key] and when I tried pressing buttons on my controller, nothing happens.

That’s very odd. Are you sure that your system has drivers to run your controller correctly?

what are drivers and i dont think i have them. if i don’t have them where can i download them

You can see drivers as a program that is a go-between between hardware and software. For example, Windows doesn’t natively have drivers for playstation controllers, but they do have them for Xbox controllers.
This means that if you were to connect your PS4 controller to a Windows system, Windows wouldn’t know what to do with it. Meaning you wouldn’t be able to use it, unless you use a third-party program (like Steam or DS4Windows) to provide the necessary drivers for it.
In this comparison, an Xbox controller would work the moment you connected it, as Windows already has drivers for it. So it knows what to do with it.

Your MacOS system and controller may be in the same situation as the Windows system with the playstation controller from the example above. In which case, you’d require a third party program to provide the necessary drivers for your controller.
Unfortunately, I don’t use MacOS at all. I could therefore not help you with finding a suitable third party program for this. You’d have to look into it yourself.

Is there a certain type of driver I should install? Maybe one specifically for binding controllers?

Drivers are specific to the hardware (controller) and operating system (MacOS, Linux, Windows).
So for using a PS4 controller on Windows, you need PS4 controller drivers designed to work on Windows.

I don’t know what controller you’re attempting to connect, but the essence is the same. You need drivers for your controller that are designed to work on MacOS.

I think I’ve found a driver suitable for me