Controller inputs not working (anymore)

Controller stopped working today. Tried rebinding controls, but inputs are not being recognized at all. Since it only stopped working today I tried reverting to older builds: (without success)
1834, 1833, 1832, 1831, 1830, 1827, 1810, 1800, 1750
The controller still works fine in other applications.

System Information

  • Operating System: Windows
  • CPU: AMD Ryzen 7 5800X
  • GPU: NVIDIA GeForce GTX 1050 Ti
  • Citra Version: nightly-1834

Diagnostic Log
citra_log.txt (5.2 KB)

Go to File>Open Citra Folder. Then delete the config folder found here. Now relaunch Citra and try mapping your controller again.

Unfortunately didn’t do the trick.
Don’t know if relevant, but the issue persists in nightly-1835 (tried your method in both this and the previous version).
citra_log.txt (5.2 KB)

Hmmm. What controller are you working with?

It’s an original Xbox One (not X/S) controller, not wireless, micro USB.
Just installed yuzu to try it out there because I thought that might be interesting, there it works perfectly fine.
Addition: clean reinstall didn’t solve it.

Yuzu has native support for a lot of different controllers. We’re actually in the process of porting over their implementation, the dev in charge is sadly very busy with irl stuff so progress has been slow.

Anyways, it shouldn’t have any issues connecting, since xinput controllers should just be mapable. If that isn’t the case, then maybe some other program is hijacking it. Do you have something like Steam open? Steam can sometimes do something similar.

Turns out it was in fact Steam, closing it solved the issue. Has been open for quite some time, and even after opening it again it still works so it probably really just decided to act up.
Thank you so much!

1 Like

Hello, I tried using using a Xbox one remote on the latest citra canary build (2630) & it doesn’t seem to recognize it via Bluetooth on Android

This topic is 8 months old and I don’t think it is related to your question, please open a new topic.