Controller Not Being Recognized for Keybinding

Issue:
I have the 8BitDo SN30 Pro+ controller. Its capable of bluetooth, but I use it plugged into the usb port because of all the issues most clients have with bluetooth. It works perfectly with all my Steam games. I recently tried to set it up with Citra, but when at the controls menu, attempting to configure it leaves every button with “press key” and it doesn’t recognize that I’m pressing the buttons on my controller. It does recognize when I click random keys on the keyboard, but not on the controller.

I tried a 2017 workaround someone had made by pasting data into the qt-config file, but that didn’t work either.

(system info may be off, this is a new laptop and i don’t know shit about graphics card, etc)
System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5-10300H CPU @ 2.50GHz
  • GPU: NVidia GEForce GTX 1650
  • Citra Version (found in title bar): Citra Nightly1678
  • Game: Pokemon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar): No?

Diagnostic Log
Useless, as the program is simply failing to recognize a controller, so logically it would not log something it doesn’t even know exists.

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Try click on Auto Map at the bottom. Citra should work with any controller that is recognized in joy.cpl (just search for it near Start). You might have to calibrate it in Windows’ gamepad settings.