Controller won't fully connect to Citra

Issue:
This isn’t the first time I’ve used Citra nor is it the first time I’ve hooked up the very same controller to Citra, so I really can’t tell what the issue is. Basically my controller sorta won’t connect. When I hit the controller buttons like A, B, X, all of that to map to my own buttons, it instead maps to keys on my keyboard. Sometimes I can get it to map a button or two to my controller, most of them will absolutely not map though. I’ve tried updating my PC and Citra itself (this has sometimes helped in the past), but it didn’t this time.

System Information

  • Operating System: Windows 10
  • CPU: Intel® Core™ i5-8600K CPU @ 3.60GHz 3.60 GHz
  • GPU: NVIDIA GeForce GTX 1070
  • Citra Version: Nightly 1765
  • Game: Pokemon Y (pretty sure the game is irrelevant to the issue at hand though)

Diagnostic Log
citra_log.txt (5.4 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

No game was booted in your log. If you are experiencing a crash then do not open citra again until after you posted the log as it gets purged when you reopen citra.
For more information, see How to Upload the Log File

What controller are you using and do you have any third party apps such as AutoHotkey open in the background?

Update: it started to work again. Sorry for the late reply, after waking up to it suddenly working again I just sort of forgot I started this thread. I still have no idea what could have caused this though.

To answer both your questions, I use a PowerA Spectra wired controller made for the Switch but has worked perfectly for my computer. I didn’t have any programs like that open either.