Controls on PC are broken

Issue:
I was playing fine for a couple weeks until a few days ago when my controls suddenly stopped working correctly in the middle of playing. It does not matter what controller i use or even if i use the keyboard. The issue is that no matter what i bind to c-stick in the config it will not work in game(any game) if i press those keys/sticks and than regardless of what i bind to circle pad in the config if i press those keys/sticks they act as the c-stick controls. In addition before i had the stick issues if i pressed my right trigger it would instantly reverse the binding and get stuck pressed(if i pressed the trigger it would act as if i was letting go). I have tried uninstalling, deleting all files including the user directory and doing a fresh install. Have also tried both nightly and canary. I am at a loss. To point out again i have tried multiple controllers which i know work fine as well as my keyboard. Would greatly greatly appreciate any help here.

System Information

  • Operating System: win10 pro
  • CPU: fx-8350
  • GPU: gtx970
  • Citra Version (found in title bar): latest(nightly and canary)
  • Game: any
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (24.0 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

like, literally while playing? or did you close citra and citra updated and then it stop working?

pretty much ya. it may have been when i went to my secondary monitor and back to the emulator on the main monitor or just while i was working on my second monitor. I vividly remember seeing the emulator window flash a split second and after that controls were broken.

Try setting up a clean and isolated (portable) citra folder, do the following:
download the latest nightly build, extract to a folder, and inside this folder (where the citra-qt.exe is located) crease a folder and name it user. this sets up a standalone citra folder in portable mode. the user folder is equivalent to the C:\Users\%username%\AppData\Roaming\Citra\ folder.

Open citra-qt.exe, configure your controls and try launching a game, since the user folder doesn’t have the system archives some games may not work, if no game works, copy your nand folder inside the user folder.

btw, what controller are you using?