Crash when attempting to open "Configure" menu

When trying to open the Configure (Settings) menu, Citra goes into “not responding” for a while and then eventually looks greyed out, as if the menu had popped up in the foreground yet nothing is there. and then attempting to click on the icon in the taskbar makes it crash completely.

The only one that’s working for me right now is the one I’ve been using for a while which is Citra Nightly 1716. And even then it goes into not responding for 10-20 seconds before Configure menu opens

Attempting to use any new stable, nightly, or canary build has the same behavior that I described at the start.

  1. My system works great with 40+ emulators and running any game, never had this issue with anything else

  2. My GPU Driver is up to date, makes no difference

  3. I deleted the settings file and the entire Citra appdata folder and started from scratch, and even attempted to do a portable version by creating a user folder. the strange behavior remains the same

  4. Running a game works fine on those builds. just can’t open the configure menu

I’m stuck. I have no idea what is causing it

  • Operating System: Windows 10 Pro 1909
  • CPU: i7-9700k
  • GPU: GTX 1080ti Duke
  • Citra Version (found in title bar): Newest build of stable, nightly or canary
  • Game: N/A
  • Screenshot of Issue (include the full Citra window including titlebar):

Better yet here is a video: Imgur: The magic of the Internet
In the last couple seconds is when i click on the taskbar and it crashes, but as you can see after it goes into not responding
it looks like it gets out of focus and there’s no way to change that

citra_log.txt (5.1 KB)

We’ve had multiple users reporting weird issues with Citra on Windows 10 version 1909. Try updating to at least Windows 10 version 2004. I personally think it has something to do with qt (what we use for the GUI), but we honestly don’t know. Let me know if the issue persists on a newer or older Windows version.

Unfortunately when I tried to update a month ago it screwed up my computer big time so i had to roll back to 1909

Is there no other work around? Anything I can install or modify to fix any issues with qt?

That in and of itself is a big red flag. I would definitely re-install Windows entirely before it decides to off itself at some point if I were in your shoes.

Unfortunately, I’m not aware of any way to circumvent this issue on Windows 10 1909. Updating (or downgrading) the Windows version is necessary for Citra to work properly.

So I’ve got 21H2 installed (unrelated, but my PC issue was caused by QuickSFV. uninstalling made everything work fine)

OK so I’ve tested the new Nightly/Canary builds and the configuration menus now open. but they are frozen for 15-30 seconds before they do. Still not sure why that is