Crash when launching game

Issue:
Enter a description of your issue here, in full detail.
I uploaded the latest version of Citra today. It crashes when I launch a game.
I’m not an expert.

System Information

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Try turn off Disk Shader Cache in the graphics options in Citra.

citra_log.txt (12.0 KB)

System Information for Support

Client Version                                Nightly 1565 HEAD-2e24183
Operating System                              macOS Mojave (10.14)
CPU                                           Intel(R) Core(TM) i5-7360U CPU @ 2.30GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             Intel(R) Iris(TM) Plus Graphics 640
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You have GDB debugging enabled. This will cause Citra not to launch games. This is only intended for debugging purposes and should be disabled in settings.

Please, where do I find Disk Shader Cache ?

Please, where do I find Accurate Multiplication ?

I just mentioned that Disk Shader Cache is in the graphics options :stuck_out_tongue:

Though you are freezing because you have GDB Stub enabled, turn it off in the Debug tab.

image

Ok let me have a try !

The game launches !
But no image…

There is a bug on macOS where you might need to resize the window or toggle fullscreen.

I got images !
But the animation combat lags a lot.
Do I have to resize the window ?

No, this is like one of the limitations of using a Mac, you get less performance than using a Windows machine I’m afraid :confused: you can turn off the combat animations if you want battles to go faster (though I suppose you can just press start to skip them entirely).

Disk Shader Cache should help with this but then you need to enable Accurate Multiplication in the Advanced graphics options in order to not get a bug which will lead to a crash if you don’t enable it.

Thanks,
I’m gonna try what you said.
I used Citra before on the same Mac and there were no lags.

It’s better.
Today, you just SAVED MY LIFE :slight_smile:

Thank you so much :grinning:

1 Like

Anyway, I got to deactivate combat animations. They provoke so big lags, almost freezing game.

Yeah they are demanding even on good hardware on PC. Though with Disk Shader Cache it usually becomes fine when it’s built up.

citra_log.txt (4.0 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.