Crashing and stuttering on AMD

Hello,

I tried many things but I can’t make the emulator work. Tried it on Zelda Link’s Awakening and I either got black screen with sound or 15 fps max, or simply a crash. Any advice for an AMD user ? I know AMD configs are quite bad for this emulator but maybe we can make this work…

AMD Ryzen 5 2600 3.4 ghz
Radeon RX 570 Series
16GB Ram

Cheers

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Please provide a log file after one of the crashes.

yuzu_log.txt (979.6 KB)

System Information for Support

Client Version                                yuzu 434             . HEAD-mainline-636-3732-g5725f83bc
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 2600 Six-Core Processor             | AVX2 | FMA
Graphics API                                  OpenGL 4.3.1
Graphics Renderer                             Radeon RX 570 Series
GPU Driver Version                            20.9.1 27.20.12029.1000
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

Sorry didn’t realize i had to run the game, the log previously was empty :x

Update your GPU Driver.
https://www.amd.com/en/support/graphics/radeon-500-series/radeon-rx-500-series/radeon-rx-570

Oh so the radeon software isn’t giving the most up to date drivers hmm
Thanks I’m trying this out

I don’t know if it gives the most up to date drivers, I download manual the drivers without Nvidia GeForce Experience software or Radeon software.

I still have the same output. Black screen with sound, “15 fps” displayed on the lower right corneryuzu_log.txt (168.7 KB)

System Information for Support

Client Version                                yuzu 434             . HEAD-mainline-636-3732-g5725f83bc
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 2600 Six-Core Processor             | AVX2 | FMA
Graphics API                                  OpenGL 4.3.1
Graphics Renderer                             Radeon RX 570 Series
GPU Driver Version                            20.11.1 27.20.12033.2007
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

First thing, should I use OGL or Vulkan here?

OpenGL is best for Nvidia for AMD not so good, try Vulkan and see how it works.

Same output. yuzu_log.txt (900.7 KB)

System Information for Support

Client Version                                yuzu 434             . HEAD-mainline-636-3732-g5725f83bc
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 2600 Six-Core Processor             | AVX2 | FMA
Graphics API                                  Vulkan 1.2.152
Graphics Renderer                             Radeon RX 570 Series
GPU Driver Version                            AMD proprietary driver 2.0.158
Use Async GPU                                 [x]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Do you have the settings like this, and what game you are trying to play.

I didn’t, but I tried with the second one (vulkan config) and had the same output.

What game you are trying to play.

Link’s awakening, is this a demanding game?