Custom layout has no effect, config keeps resetting

Issue:
I’m trying to set up a custom layout to split the screens between my two monitors. I’ve tried multiple configs from other users and created my own, none work properly and just leave the default sized emulation window on my second monitor. I also found that if I don’t set my qt-config file to Read only, Citra will reset the custom layout options every time I start a game.

System Information

  • Operating System: Windows 10
  • CPU: i5 8600k
  • GPU: GTX 1060
  • Citra Version (found in title bar): Canary #658
  • Game: Any
  • Screenshot of Issue (include the full Citra window including titlebar): https://i.imgur.com/Gkvnga6.png

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (11.3 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Did you do custom_layout=true?

Yup. Again, if the file is not set as Read Only, Citra immediately toggles it back to false again.
Even if read only is enabled, there doesn’t seem to be any changes in my layout.

That’s really strange. Can you post your config file?

Gotcha.
https://pastebin.com/g2Pd9GR6

That’s the state it resets to at least.

Change those /defaults below custom layout to false.

cc @zhaowenlan1779

1 Like

That fixed it! No idea why I didn’t think of changing the defaults first…
Thanks!

Eh, it’s not too intuitive in my opinion. I don’t think that custom_* should have defaults.

1 Like

Yeah, personally I thought it was the settings that Citra would revert to upon triggering some Reset to Default function myself. Does Citra just do that on every start then?

@DjBlades yes it reverts settings xxx to default if xxx\default is set to true. And that is done on start.

@Adityarup_Laha Well I just tried to keep consistency. And I didn’t want to “choose some” settings to do the defaults fix.

But these settings don’t need a default at all. That’s what the custom_layout setting is supposed to do.

They actually have a default :frowning: And the default values are the “Default” layout.
My PR is just default settings fix, and I cannot remove default values in it.