Dai Gyakuten Saiban 2 - Game Video Freezes but Audio continues normally

Issue:
The game menus and audio work just fine. Once I start the game, a white screen fades in like it’s supposed to but then the game is frozen on the part shown in the screenshot. The audio still continues as normal.
Something interesting to note is that this error doesn’t appear on my PC which has an AMD FX 6300 and an Nvidia GTX 950. What I don’t understand is why this is happening on my laptop.
Also, since this is Dai Gyakuten Saiban 2, the first game Dai Gyakuten Saiban 1 should work similarly but I haven’t tested it.
My drivers are already all up to date, I’m pretty sure I’m using my dedicated AMD GPU and not the Intel one and I already have the latest Visual C++ redistributables installed. Changing Accurate Multiplication didn’t do anything either.

System Information

  • Operating System: Windows 10 Home 64-bit
  • CPU: Intel Core i5 8250U @ 1.60GHz
    Kaby Lake-U/Y 14nm Technology
  • GPU: Intel UHD Graphics 620 (HP)
    2048MB ATI AMD Radeon R7 M440 (HP)
    CrossFire Disabled
  • Citra Version (found in title bar): Canary 1829
  • Game: Dai Gyakuten Saiban 2
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (16.2 KB)

System Information for Support

Client Version                                Canary 1829 HEAD-6c7a01c
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics 620
GPU Driver Version                            23.20.16.4973
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Never mind. It seems like I was actually not using my AMD GPU. It seems like Windows 10 doesn’t let an application use the dedicated GPU until you specify it in the settings. According to a reddit post I saw:

“You can do this through Windows. A Windows update has made windows think the integrated graphics is a better choice. To force it to use dedicated to to Settings, then System. Scroll down to Graphics Settings. From here ensure “classic app” is selected and click “browse”. Find the .exe file for the game you’re running and select it. Once it’s been added to the list click “options” then select High Performance.”

The game works fine now.