Devil Survivor 2 Record Breaker

Issue:
Enter a description of your issue here, in full detail.

At first it seems the game is working perfectly, but…

Unable to deploy Daichi during the second battle of the game where Makoto joins during a Septentrione start. Daichi’s death clip is shown at the beginning of the game and the player must go to Asakusa Sensouji to intervene during Daichi’s Crisis and rescue him. You can try to edit team and put him where he belongs and even edit his skills, but you cannot position him or even start the battle since his deployment is required.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core I5-8300H CPU at 2.3GHz (eight cores)
  • GPU: Besides onboard there’s a descreet Nvidia Geforce GTX 1050
  • Citra Version (found in title bar): I tried the latest nightly and the latest canary (citra-windows-mingw-20200513-213c956 and citra-windows-mingw-20200514-0ef6ba8
  • Game: Devil Survivor 2 Record Breaker
  • Screenshot of Issue (include the full Citra window including titlebar): N/A

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. N/A

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

It could very well be that the problem is on my end. However, I have a fairly new laptop, Acer Nitro 5, upgraded to 32GB RAM and a 500GB m.2 SSD. I really don’t feel like the problem is on my end. Other games work fine on this emulator and this laptop.

It makes me believe that this game was not thoroughly tested before people ranked it as working perfectly. It’s a long game, so I understand. Maybe, the new addon content was the only parts that were tested. Either way, it doesn’t take long to get to the second battle of the original content in this game where you go to rescue Daichi, especially since you can enable skipping stuff in the settings. Could you please take a few minutes to test it, or is that too much to ask?

Here is the log file.

citra_log.txt (4.3 KB)

The onboard graphics is Intel UHD Graphics 630. That one has the problem with not being able to deploy Daichi. My descrete graphics card, Geforce GTX 1050, only shows a black screen. I cannot even run the game if I try to use that in windows 10 Graphics Settings. That’s fine, I would be happy to just use the onboard graphics for this wonderful and classic game. I hope someone can help with this problem. Cheers!

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Maybe, I need an older version of Citra?

Does anyone know how I can download an older version of Citra that was said to be capable of running this game perfectly? I went to the github page, but could not find Canary Build 6928151 from 02/22/2020 and said to run this game perfectly by akumani.

It’s the most recent build to be verified to run this game perfectly, so I thought I would try that version, but that version doesn’t appear to be anywhere on the github site, here: https://github.com/citra-emu/citra-canary/releases

Maybe I need to change the settings, but I don’t know what to change. Does anyone have any advice on that?

Thanks for taking the time to read and consider my request.

Despite the fact that I read about your problem, I can’t understand what is happening in the game (or why). I remember that I placed Daichi and the rest of the characters in the battle without any problems.

I can only give you a link to an earlier version. I completed the game on it. This is the version of the emulator, released in mid-February, 1422. If you think that the problem is in the version, then here the game can definitely be completed.

https://github.com/citra-emu/citra-nightly/releases/download/nightly-1422/citra-windows-mingw-20200221-e3dbdcb.7z

Mouse, thank you very much for replying and providing a link to a version that is verified to be working. I will give it a try and post the results later today. I appreciate your kindness! Thank you!

Okay. I just checked and nothing changed. I am still unable to deploy Daichi. As you can see in the image, Daichi doesn’t even show up so that I can deploy him. If you back out and go back in to team edit, he shows up, you can place him in the second position with his summon, then back out and try to set the team in their positions, but again he doesn’t show up in the list so that you can position him and so it becomes impossible to deploy him. It must just be my laptop and it’s onboard graphics, right? All I get is a black screen if I use the discrete video card my laptop possesses. If that version of the emulator worked for you, then that means there’s definitely something wrong on my end.

But it is still possible that the problem is in the game itself, I mean the file itself. If other launched games work without serious malfunctions, there is a possibility that a problem arises with this particular game file. You never know, maybe there is some specific error in it if the dump was made incorrectly. I am not ready to discuss dumping issues, but you should not discard the possibility that the file is faulty.

I can also focus on another possible cause of the problem. For which region is your version of the game? American or European? As far as I know, at least a patch version 1.1 was released for the American version of the game, but I can’t remember if I started the game with or without it. Also for the game there were several DLCs. Is your game the latest version? Did you install a patch or DLCs? If not, perhaps the patch just fixes this error along with others. However, they can also be the cause of the problem. This is paradoxical, but sometimes an installed patch or DLCs causes emulation errors.

If you installed them, but do not know how to remove them from the emulator, then the instruction is below.

How to delete patch or DLC

Installed DLCs and patches can be deleted without affecting the game or save files. Run the emulator and right-click on the game in the emulator list - you will see a window with several options. The first one will probably open you a directory of save files. If you separately installed patches or DLCs, then the second option will open the directory of additional files. If after installing patches and DLCs the game began to work worse, you can safely delete this small folder.

I have no other ideas yet. You probably have to wait for the help of a moderator or someone from users who are familiar with this problem.

Thank you very much for explaining all that. I agree, it could certainly be the file. I have the USA version not patched. I am not sure about the DLC. I deleted that folder you told me about and deleted all files in my games folder except this game and then restarted. The emulator recreated a folder, I assume that is what it was doing, then I loaded up the save file from right before that Daichi rescue mission. The same thing happened. It could very well be the file I have is corrupt. I really doubt my laptop is bad, since it’s pretty fast and runs smoothly for everything I do on it. I don’t install anything weird on here. I keep it pretty bare bones, except the productivity software like Gimp, Blender, Unity, Visual C++, etc. and a few games. It is unlikely my computer was infected by maleware, since I never go to untrusted sites. The game did run perfectly all the way to that battle and perfectly through the first battle of the new content, as well. I still have my old NDS lite and the original game installed on that, so I guess that’s it for me. I can’t afford another game console right now. Buying the game is one thing, but buying a game console is a bit much.

You can try to find the patch and install it, and then start the game from the very beginning and reach the problem point.

You can also re-dump the game. Of course, now we are talking about your own dump. You made your own dump and you know that discussions on where to get games are forbidden on the forum, because they are not only illegal, but they may also contain errors, and in this case moderators will not be able to help you.

If you are not sure that you are doing everything right, perhaps someone can help you dump the game correctly. That is why, of course, you have your own copy of the game, but there is no console on which you can play or make the correct dump. You cannot ask the console for long for someone to play, but you can ask for a while to help make a game file, right?

One way or another, we cannot know exactly what causes the problem with Daichi, but you can try to launch the correct dump and check if an error occurs. But be sure to start the game from the very beginning, because saving could already save the “error”.

Okay. Thank you very much for taking all that time and effort to help me. I will ask my friend to redump my game. I hope that fixes it. Otherwise, I’ll have to spend a hundred more on the console. Well it’s a wonderful game so it’s not like I am wasting money, it’s just that I don’t like the small screens of those handhelds. I hope one day they sell all of those classic Atlas games on the PC.

1 Like

My friend says his N3ds is not working. Ugh!

However, I found a website that shows how to dump the game and decrypt the file to use with emulator, so I’m just going to go buy the console and dump it myself. Thanks again for all your help!