Different Games Crashing with Similar Errors

Issue:
Almost like clockwork Super Mario 3D Land freezes around the 60 minute mark. Citra doesn’t crash, but I need to reload the game. I tried reinstalling Citra and updating my video drivers, but the issue still persists.

I tested Ocarina of Time and New Super Mario Bros. 2 as well to see if I got the same issue, and sure enough they freeze too, but after closer to a minute. I can’t find anything on the error code or anyone having a similar issue, so I imagine its a problem with my configuration somewhere.

The common line I see for every crash is

 [  10.072218] Service.FS <Error> ./core/file_sys/archive_backend.h:GetOpenDelayNs:193: Delay generator was not initalized. Using default
 [  10.073682] Service.FS <Error> core/file_sys/savedata_archive.cpp:OpenDirectory:343: Unexpected file in path C:\Users\matth\AppData\Roaming/Citra/sdmc/Nintendo 3DS/00000000000000000000000000000000/00000000000000000000000000000000/title/00040000/0007ae00/data/00000001/BigRedSave.dat

The file path changes, of course, but it seems its always “Delay generator was no initialized” and “Unexpected file in path…”

I tried tweaking a few settings here and there between games, but nothing seems to change anything.

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 7 3700X
  • GPU: NVIDIA GeForce RTX 2070 Super
  • Citra Version (found in title bar): Citra Nighlty 1678
  • Game: Super Mario 3D Land, Ocarina of Times

Diagnostic Log
citra_logSM3DL.txt (43.1 KB) citra_logNSMB2.txt (15.7 KB)

The most likely reason you’re crashing is because you bumped the CPU Clock Speed up to 400%. This makes things incredibly unstable. Go to Emulation>Configuration>System and turn the CPU Clock Speed back to 100%. If you’re still having the same issue after this, please upload another log file.

I knew it was gonna be something dumb, completely forgot I did that. That seems to have fixed it, thanks.

1 Like