Disney Magical World 2 Lag

Issue:
I have a problem when i start the game the fps is around 25-30 fps but it lags around 4-15 when i use cheats to create like decorations and food and outfits and so on so i dont know how to fix this lag.

System Information

  • Operating System: Windows 10 Home 64-bit (10.0, Build 18363)
  • CPU: Intel® Core™ i7-4770 CPU @ 3.40GHz (8 CPUs), ~3.4GHz
  • GPU: NVIDIA GeForce GTX 760
  • Citra Version (found in title bar): Citra Niglty 1468
  • Game: Disney Magical World 2
  • Screenshot of Issue (include the full Citra window including titlebar):
    Lag

Diagnostic Log
citra_log.txt (1.0 MB)

System Information for Support

Client Version                                Nightly 1468 HEAD-e480a80
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 760/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            445.75
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You are using open source system files for Mii data. This will appear as your Mii having broken graphics, but will not affect the stability of the game. In order to resolve this, please refer to our guide on dumping system files. https://citra-emu.org/wiki/dumping-system-archives-and-the-shared-fonts-from-a-3ds-console/

i did enabled accurate multiplication and i still get lag i really want to play this game

The coretiming 2.0 change caused a regression unfortunately so try Nightly 1422: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1422

I tested it but it still didnt work it happens when i press new game the intro starts i got around 14-18 fps so do i have to disable or enable some options at graphic tab to get better fps?

Upload a new log with that version. Note that “movies” are very CPU intensive so check when you can move around if it’s good or bad.

ok here it is
citra_log.txt (24.3 KB)

System Information for Support

OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Perhaps the game is just very slow on intros etc. Is it fine when you move around?

no i get around 15-17 fps when im running and walking around

I see, I can check on my end around next week. My CPU is around equal with yours: i7-3770K but have GTX 1070 instead however it shouldn’t really matter. How is it with native 240p resolution?

i dont know i havent tried it i will test it out right now and reply to you if it works.

Edit: ok so i tested it at native 240p resolution native as you suggested and i get around 13 fps.

Ok i actually fixed the solution i switched to the latest Canary it runs around 30 fps

Hm, perhaps the speedup comes from https://github.com/citra-emu/citra/pull/5214 however Nightly 1422 should have sped it up too as it was before the CoreTiming 2.0

Well glad to hear the speed is fixed :slight_smile: