Displaying the two Citra screens on two different monitors

This will not work on macOS.

Based on @BayoNX19 's work. I just found a glitch, corrected it & designed the applet to make it easy to use.
I can’t test it, but the feedback was positive. Some test results will be very welcome.
Edit: I’ve done a bit of research regarding this, all seems fine.

Step 1 : Open %appdata%\Citra\config\qt-config.ini in Windows (look at the posts below to find the path on your platform).
Step 2 : Edit the file as follows…


It should look something similar to above.

  • Change custom_layout=false -> custom_layout=true.

Step 3 : Get your config set up…

  • Download this : applet.txt (1.4 KB)

  • Change the extension to .htm.

  • Open the web page, it should look like this.

  • Enter the resolution, in WIDTHxHEIGHT format.

  • You should have a block of text like this :

  • Now replace the entire block of text (corresponding to these settings) with these lines.

  • Run Citra. Everything should be working fine, & hopefully, it would be working!

  • If you get an error, try switching the Main Monitor & the Secondary Monitor. If you still have problems, fell free to ask for support or PM me directly.


@moderators Please mark it as a tutorial.

Hexagon can you test this? Iirc, you encountered a glitch in the original thread. I found out where it was, & have corrected it.

The configuration keys and values should be the same. As far as configuration file paths go, this wiki page details the differences across platforms.

Thanks! I thought so, but I wasn’t sure.

Hi I am having issues getting this to work. The most it has worked is made the main window full screen but the other screen is no where to be found. I messed around with some the numbers for the resolution and can make it show up on top of the main screen. It doesn’t actually seem to separate onto my second monitor.

My main monitor is 2560x1440 and is on the right side and listed as ‘2’ in the display settings. My second monitor is 1920x1080 and on the left and listed as ‘1’.

I have tried switching around the monitor configuration to no avail. It literally seems like the second screen is unable to open on the other monitor. Thank you for this tutorial and hopefully you can help me with this

Can you try in full screen?
And, please keep in mind that I only made the applets. Though I’ve done a bit of research on this, the only suggestive thing is that there is some kind of access restriction or else its a internal Citra issue. Also, try following the tutorial once again (just in case you made a slight error). If the issue still persists, contact me in PM, with step by step details of what you did & please include your config file.

1 Like

So with some help from Reddit, I was able to figure out the main issue here. So all the numbers were correct and in the right place, however the issue I was having was indeed fullscreen. As soon as I would hit F11 to go fullscreen, the other screen disappeared. So what I had to do was expand the little screen by dragging it from one side of the monitor to the other. This then allowed both of the 3ds screens to show full screen on my monitors. Hopefully this helps anyone else who comes across a similar issue!

1 Like

I have tried it a few times but I do not get a good result. My main monitor is 1920x1080 and my secondary monitor (which is on the left of the main monitor) has 1280x1024. Now I want z.b. Ocarina of Time play where the map is to be displayed on the left screen and the main image on the main monitor (and on the main monitor without ugly edge). What do I have to do now to make this work?

Did you try swapping the monitors? And what sort of result do you want? I never played OoT, so I’ve no idea what you’re asking for.

I would not fool the monitors, there is no room for that. On the 3Ds is the screen and the map and the inventory. I want to have the main screen of the 3DS on my main monitor (on the right) and inventory on my second monitor (on the left).

You are extending the left display to include the right display, right? Then this tutorial should work… I suppose you are on Windows?

yes i am using windows. So it did not work that way for me. I was missing the lower ds screen.

Please extend the displays via the inbuilt options & try.

Which built-in options? I have already clicked everything in Citra what it is ^ ^.

Using Windows’ control panel.

I do not understand what I should change in the control panel everything is set correctly. Can not you just tell me what I have to enter in Step2 for my monitors? That would be really nice.

Sure, but you unless you use the Windows’ display extend, this might not work. Just Google for “Windows 10 display extend”. Then just follow the usual steps, you should be fine.

I think we do not understand each other somehow. I’ve watched videos, but they do not kill me. Nevertheless, thanks for your effort, even if it has brought me nothing.

Thanks for the tutorial!
It’s definitely not perfect, but with some fiddling I could make it work for me. To help others, I’ll describe my setup + method.
First, my situation is I have a secondary 1680x1050 screen to the left, and a main 2560x1440 screen in front of me.
When I plugged those numbers into main.htm, it assumed the screens were the other way around. So I had to change this:


To this:


This is pretty good, but has 2 issues:
The screens get stretched to fill this space, rather than maintaining aspect ratio
This doesn’t account for the space the window frame takes, so a bit gets cut off at the bottom (and more at the bottom/side depending where your taskbar is, if it’s not hidden).

So I found the correct aspect ratios for the screens (5:3 for top and 4:3 for bottom), found the screen height I had available without window frames (I assumed 90px, it’s less but this is perfect with room for the status bar).
So my main screen is 2560x1440, giving the game a size of 2250x1350.
My second screen is 1680x1050, giving the game a size of 1280x960.
To figure out the padding, take the game width from the screen width and halve it. I have my taskbar on the right so I took out an extra 66 pixels for that, so my numbers are weird.
After plugging all the numbers back in, I have this:


Of course my specific numbers are for this weird screen setup, and my weird taskbar, so I don’t expect those specific numbers to help anyone at all. Hopefully if anyone has a similar issue this helps you though! And maybe some of these extra settings could be built into the calculator?

This was expected. The tutorial is designed for fullscreen on both screens, so stretching is normal. Also, the bit of screen that’s covered by the frame is arbitrary, so I can’t do anything about it, one will have to manually tweak the settings.