Displaying the two Citra screens on two different monitors


#21

that would be a good idea. Let’s see if I can get it now with me.


#22

Can you tell me what data I need to put in for my monitors? My main monitor is 1920x1080 and my secondary monitor (which is on the left of the main monitor) has 1280x1024.


#23

custom_top_left=1280
custom_top_top=0
custom_top_right=3200
custom_top_bottom=1080
custom_bottom_left=0
custom_bottom_top=0
custom_bottom_right=1280
custom_bottom_bottom=1024

I am not too sure, but I think this might work.


#24

Unfortunately, I did not really work, but many thanks to all for the effort.


#25

Hello
Thank’s for the tutorial, i have few questions.
Are you using Nvidia surround ? The only way for me to have citra running in fullscreen on both monitor is to use nvidia surround, i guess it made my two monitors like “one” big monitors. If i don’t use nvidia surround, i can’t have full screen on both monitors, it only fullscreen on one. The issue is that i don’t want to use nvidia surround because it’s not giving me the proper resolution and my image get deformed. I don’t understand how you guys can go fullscreen on both monitors. can someone help me ?


#26

Actually, I don’t have 2 monitors to test this. See the first part of the post.


#27

Thank you for your response.
Yeah i know but some people said it’s working for them, and i really don’t understand how if they don’t expand the 2 monitors into one big screen. When i search the internet to find how to fullscreen program on 2 screens at the same time, people seem to have real problems doing it. When using nvidia surround you have only one ultra wide resolution. But in the layout config you guys are sharing, you seem to be able to do it with 2 resolutions (even different ones). (sorry if my english is weird, i’m french).


#28

Hi,

I would like to share with you an updated version of the web page. Here it is : main_v2.1.txt (3.8 KB)

I have just added the possibility to keep the aspect ratio (screens are centered instead of streched) and to switch top / bottom screens.

On my two 1080p motinors values are ok, but tell me if you have any trouble and I will check the code.

Have a nice day !

Edit: I have made a few modifications, now screens are vertically centered if your monitor ratio is below the 3DS one. Hope you like it !


#29

So I have tried inputing those settings and doing everything you guys have said so far. Just that no matter what I do, it just doesnt change anything. I see that In am supposed to change qt-config and you say it should look like what you guys have shown. mine however looks like this as its default before being changed.

[Layout]
toggle_3d\default=true
toggle_3d=false
factor_3d\default=true
factor_3d=0
layout_option=2
swap_screen\default=true
swap_screen=false
custom_layout\default=true
custom_layout=false
custom_top_left\default=true
custom_top_left=0
custom_top_top\default=true
custom_top_top=0
custom_top_right\default=true
custom_top_right=400
custom_top_bottom\default=true
custom_top_bottom=240
custom_bottom_left\default=true
custom_bottom_left=40
custom_bottom_top\default=true
custom_bottom_top=240
custom_bottom_right\default=true
custom_bottom_right=360
custom_bottom_bottom\default=true
custom_bottom_bottom=480

EDIT: So I managed to get the top screen to work and go fullscreen maintaining aspect ratio and what not, but the bottom screen is nowhere to be found. Any other ideas?

EDIT: 2 So I managed to get it to work but not in fullscreen the task bar is still on the bottom and the white bar at the top is still there. Might be posted somewhere else but I can’t seem to find it. any ideas on how to make fullscreen take up both displays?


#30

Set the defaults of the particular settings to false. This topic hasn’t been updated in a while, so is a bit hard to get it to work. Also, I don’t have a multi-monitor setup to test.


#31

I got it to work sort of but it cant go ful screen because when i go full screen it goes only on one monitor. I have to stretch the window.


#32

Hmm, no idea why this happens. Sorry I couldn’t help.


#33

I know there is an option with nvidia control pan. to customize resolution instead of two separate displays, as well as to enable full screen over both monitors but my gpu does not support it :frowning:

I have however found a more enjoyable setting, I just changed the ratio of the screen to be a little bigger on the small screen, similar to large screen but more evened out.


#34

I followed the tutorial however i can’t get the second screen. As you told me in the other post this tutorial is outdated do you know if it’s still working?


#35

It may or may not work.