DKCTF 1.0.2, weird issue (unplayable)

Hi there :slight_smile:

I have a weird problem with DKC TF (update 1.0.2):

  • a while ago I tried to play v1.0.0 for the 1st time on Yuzu. After the (very long) intro and setting menu, the game launched and I could play. However, I quickly stopped since the sprite of DK was kind of messed up. Its shape was not right as if the character was stretched or something. At a moment it became absurd. I decided I’d look into that later.

  • Now I applied update 1.0.2 and restarted from scratch. At the end of the (still very long) intro, I get major glitches. The screen looks like a brownish mosaic. GPU usage goes to 100% and GPU temp quickly increases to dangerous levels. After a few seconds, the GPU fails (black screen, fans run at full speed). I can still access the PC remotely and I get 2 error messages: One saying Yuzu crashed and one saying the display driver crashed or something. If I reboot, I lose remote access but the PC doesn’t actually reboot. A hard reboot gets me back to the desktop with the GPU being disabled (windows cannot load its driver). My only way out is to uninstall the GPU and then everything is back to normal after the next reboot.

Other games don’t give me that kind of shit.
Reverting to v1.0.0 of DKC TF restores the previous behavior (“minor” graphical glitches).

Is there anything I could try?
Should I try to fix v1.0.0 or rather v1.0.2?

Thank you very much in advance for your help.

Best,
-a-

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Log please when you can.

Thanks @Ghost666
You mean, when playing v1.0.0. or when playing v1.0.2?

whatever you can provide.

Hi @Ghost666

Log file sent as DM.

Again, weird…
I launched DKCTF v1.0.0 again and this time, after the long intro, just when the game normally starts (when you bump out of the crashed plane), it didn’t go as previously (game is mostly normal but DK’s sprite is stretched/wrongly shaped). This time I got the brown mosaic (same as when I was trying to run v1.0.2). I tried to stop Yuzu ASAP and managed to force-exit it (crash) without the PC or the GPU crashing.

This seems to indicate that my problem is not necessarily linked to the version of the game and is more random than previously thought.

Let me know what you think about it.
Thanks a lot.
Best,
-a-

Hey :slight_smile:

As recommended by @Edward on Discord, I tried OpenGL instead of Vulkan and now the major graphical glitches are gone. I get 60fps but the game stutter quite a bit. I guess I’ll need to fine tweak the settings if it becomes too annoying.

NOTE: I know from a YT video the game was running fine on Vulkan in Yuzu EA890 (Aug2020). I guess something was changed since. Maybe it’ll come back to normal some day. I’ll try periodically to switch back to Vulkan for this game when I notice Yuzu got updated.

Well the game is playable now but there are still many graphical issues (mostly textures that are not properly rendered I guess, like the water is green or stuff like that…).

Also I noticed that whenever I stop the emulation, yuzu stops responding and crashes.

Let me know if there is anything I could do to change that other than wait for an update of yuzu mainline.

I use GLSL since GLASM is marked as “NVIDIA Only” and I have an RX590 (and SPIR-V is marked as “Mesa Only” but I believe this is for those running Yuzu on Linux).

Switching resolution scaling from 2X to 1X seems to help with the “green water” issue

EDIT: Don’t know if that mod would help (it’s for 1.0.0 IDK if it’d work with 1.0.2):

https://github.com/theboy181/switch-ptchtxt-mods/raw/main/Donkey%20Kong%20Country:%20Tropical%20Freeze/[0100C1F0051B6000]/1.0.0/4K-2K.rar

EDIT2: nope… the 2K-4K mod has no effect (neither on 1.0.0.nor 1.0.2): water is still green when res scaling is at 2X