Download Play in Canary Builds

Issue:
I saw in this post that canary builds have Download Play support. I dumped my config savegame from a NAND backup using ninfs and 3ds-save-tool. I also went into View > Debugging > Toggle LLE Service Modules and checked the box for DLP from there. But when I try to launch Download Play and tap on the Nintendo 3DS option, it tries to find software for a few seconds and then completely hangs the entire emulator (only way to quit is to force stop the app). I have attached my log below, any help is appreciated.

System Information

  • Operating System: Ubuntu 20.04.1 LTS
  • CPU: AMD Ryzen 5 3550H with Radeon Vega Gfx
  • GPU: AMD Radeon RX 560X (Mobile)
  • Citra Version (found in title bar): Citra Canary 1872

Diagnostic Log
citra_log.txt (4.7 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Another note: If I try to open a DLP title like Mario Party: Island Tour and start the Multiplayer mode, it instantly throws me out and restarts the game after the message: A communication error has occurred. Please Press OK to return to the title screen.

Ok I fixed the issue of Download Play crashing by dumping all my system modules. I still get the same error when trying multiplayer in Mario Party: Island Tour (Communication error has occurred). Can anyone please help? (Here’s an updating log if it helps: citra_log.txt (40.0 KB))

System Information for Support

Client Version                                Canary 1886 HEAD-6f8ea3cef
Operating System                              Ubuntu Core 20
CPU                                           AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx  
Graphics API                                  OpenGL ?
Graphics Renderer                             AMD POLARIS11 (DRM 3.35.0, 5.4.0-53-generic, LLVM 10.0.0)
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Ok issue has been fixed by copying the entire “title” folder from my NAND backup to “(citra folder)\nand\00000000000000000000000000000000”. I must have missed some app / applet necessary to run it properly.