Dragon Quest VIII: Bird shadow is missing

Issue:
In this game there is a part where you need to follow a certain bird shadow, but as of nightly build 1285 it won’t appear. I’m positively sure I did everything needed on the game for this event to happen.

On an older topic in this forum someone suggested using an older build, but I couldn’t load the savegame from it. I tried overwriting (made a backup before) the citra directory but it just bugged a bit.

Anything?

System Information

  • Operating System: Windows 10 Pro
  • CPU: Intel Core i3-3210 320ghz
  • GPU: Integrated Intel HD
  • Citra Version (found in title bar): nightly-1285
  • Game: Dragon Quest VIII: Journey of the Cursed King
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Uplcitra_log.txt (92.2 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1285 HEAD-c81a96b
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 2500
OpenGL Version                                3.3.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Screenshot as requested (cannot put 2 links as new user)

Imgur

Is it just a graphical error where the event is occuring but the shadow doesn’t render? If so, just walk over to where the dark portal normally appears (It’s always in the same place, unless the 3ds version changed things). If the event itself isn’t occuring, that seems unlikely to be a problem on citra’s end.

The event is happening since I can hear the bird’s screech. But I’ll try to walk straight to the portal

Try disabling hardware shaders. The game will slow down, but you might be having a graphical error with it. (This also might be one of the few edge cases where accurate multiplier would also help, but I doubt it. If you want to try that first, do so before turning off hardware shaders) (These settings do require citra to reboot)

Disabling hardware shader made this lovely bird appear on my screen lol https://imgur.com/LZmx0CE

Disabling hardware renderer at all WILL make the shadow appear but it’ll slow down the emulation to like 5% speed, making it impossible to play

Also I went to where the portal appears but nothing happened… you have to follow the shadow

I don’t know if this helps but this is where someone suggested to use an older version. I just don’t know how to load the savefile from the newer version so I can get past this part.

Interesting. It looks like it’s some OpenGL stuff we didn’t get done. The older version might help then, you should be able to find that on the site under manual downloads. should be able to swap back afterwards as well. As old as it is, however, it’ll probably be significantly slower.

I used the older version on the linked topic, but when I load the savefile it will freeze the emulator after 2 seconds.

I will try to move the Citra files to a more potent computer and try again.

Hi, I read through the log and your GPU doesn’t support the OpenGL extension that we require to render that specific kind of shadow. That’s not surprising considering your GPU is the first generation from Intel to support OpenGL 3.3

Hey, it took me a while but I tested it on a newer and better computer (with a geforce 1060) and the shadow was there just fine using the nightly build 1285. I didn’t need to use an older version. So it was really an old harware issue.

Thanks everyone!

Hey guys, sorry for necroing this, but I have the same problem with the Android build. I have Snapdragon 865. Any solutions?

hello, I have the same problem, I can’t see the birds shadow as it won’t appear

citra_log.txt (4.0 KB)
citra_log.txt.old.txt (202.3 KB)

and when I try to disable the hardware shader option it shows me like this witch is useless

please help

System Information for Support

Client Version                                Nightly 1716 HEAD-62236b7
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz | AVX
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.5161
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Downloads for Graphics
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

citra_log.txt (4.0 KB)