Dragon quest VIII can't climb ladders

Can’t climb up the ladder in alexander tower:
So i was replaying dq8 (I have completed it with citra about 3/4 months ago) and i seem to be stuck in alexander tower. There is a room where you have to click on a ladder to climb it and no matter what i do it just wont click. I have played this game many times so i know im not doing anything wrong and should be able to click it, but it is just not happening.

I tried changing 3ds files, making a brand new file, changing graphics settings but nothing seems to work. Any idea if this is a citra related issue? i have been able to do it in the past, but I remember struggling last time too with this exact ladder. It took me maybe a couple minutes to click on the ladder last time in march, but now after hours of trying i just cant do it

System Information

  • MacOS Sierra 10.12.6:
  • CPU: 2,7 GHz Intel Core i7
  • GPU: NVIDIA GeForce GT 650M 1024 MB Intel HD Graphics 4000 1536 MB
  • Citra Version (found in title bar): Citra Nightly HEAD-50def5a
  • Game: Dragon Quest VIII (eu/us versions)
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (27.0 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Research if this is a game related bug/feature. If this did work before which would be a weird bug for citra, bisect it by testing previous builds (click manual download on the download page).

1 Like

I think i solved it! tried your suggestion of trying a previous build and noticed that it was remembering my configs from other builds, so i completly removed any citra related files. That reset my input keys to the default, which now worked. That made me realize i had the A button set to the same as the C-stick down button ( a button i never use in this game). having them bound to the same for some reason meant ladders couldnt be climbed. A worked fine in all other cases, but ladders are fiddly and i think they dont want you to press more than 1 button at a time to work.

Thanks for the help leo!

2 Likes