Dragon Quest VIII Journey Of The Cursed King Freezes/ Doesn't Work

Issue:
Whenever I load up the CCI file for DQ8 it loads up a black screen and crashes the citra program and doesn’t work, however sometimes it loads up the “square enix” screen and then decides to freeze there instead. I have re installed citra, and the game itself, i have tried mulitple versions of the game (EU/ USA) but the outcome is the same. The game however only worked for the first time and then didn’t work after that; every single time after that it crashes, and causes citra to crash too. I know my PC isn’t ideal for gaming but it can handle other games and has ran this game before so i don’t understand why it isn’t working.

System Information

  • Operating System: Windows 10 Home
  • CPU: Intel® Core ™ i3-220 CPU 3.30GHz, 3300 MHz, 2 core(s) 4 Logical Proccessor(s)
  • GPU: Intel® HD Graphics
  • Citra Version (found in title bar): 1627
  • Game: Dragon Quest VIII Journey Of The Cursed King
  • Screenshot of Issue (include the full Citra window including titlebar):

    citra_log.txt (13.9 KB)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1627 HEAD-aced133
Operating System                              Windows 10 (10.0)
CPU                                                   Intel(R) Core(TM) i3-3220 CPU @ 3.30GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 2500
GPU Driver Version                            10.18.10.4358
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [ ]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. https://downloadcenter.intel.com/product/80939/Graphics-Drivers
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • LLE Audio is designed for debugging purposes. Using this option will slow down your game. Try changing to HLE audio.

For updating your drivers:
Download win64_15.33.51.5146.zip (direct link) from https://downloadcenter.intel.com/download/29802/Intel-Graphics-Driver-for-Windows-15-33-?product=65693

Then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

After you’ve done the above, enable Hardware Shader and Shader JIT (found in emulation>configuration>graphics>advanced tab).
Switch from LLE audio to HLE audio (found in emulation>configuration>audio).
Lastly, you may want to switch New 3DS Mode off because it may cause freezing with your GPU (found in emulation>configuration>system).
If this last step doesn’t work, you may need to use an older version of citra.

Hey, i adjusted everything like you said and it seems to be working fine, thank you so much! BUT, whenever i load up a save file within the game, citra crashes…idk why, everything was perfect a second ago.

Save file or save state?

A saved file. I loaded up a different version of dq8 though since i have 3, but do you know any way to keep the speed around 100% since mine is always around 70%?

Disable custom textures + texture filtering. Though I doubt that will get you up to 100% honestly.

Yikes, i never even had custom textures or a texture filter on, i’m screwed.

Taken directly from your log mate:
[ 0.004233] Config <Info> core/settings.cpp:operator():75: Utility_CustomTextures: true
[ 0.004224] Config <Info> core/settings.cpp:operator():75: Renderer_FilterMode: true [ 0.004225] Config <Info> core/settings.cpp:operator():75: Renderer_TextureFilterName: Anime4K Ultrafast

Yeah, that log was before the game was running, i reinstalled citra and reset the settings, the custom textures and texture filter is off.

So, there’s nothing you can recommend that i should do to increase the speed?

I only had your previous log to go off of. Which you already said was no longer valid.
Upload a new one so I can actually see if there’s something you can tweak.

Okay gotcha, here.

citra_log.txt (87.3 KB)

System Information for Support

Client Version                                Nightly 1628 HEAD-1c8461f
Operating System                              Windows 10 (10.0)
CPU                                                   Intel(R) Core(TM) i3-3220 CPU @ 3.30GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 2500
GPU Driver Version                            10.18.10.5146
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. https://downloadcenter.intel.com/product/80939/Graphics-Drivers
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Ignore the bot regarding the drivers, it’s a bit dumb when it comes to old GPU’s xD.
Enable hardware shaders in emulation>configuration>graphics>advanced tab. That should increase the speed by a lot.

1 Like

It’s fine lmao, and my speed went from 40% to 95%+ !! thank you sooo much, i appreciate it (: Hopefully this fixes any problems for now ahah.