Dream Team motion controls not working in battles on Steam Deck

Whenever I try out the motion control attacks in the practice attacks mode, the gyro works, but when I am in an actual dream battle, they stop working, and I have no idea why. I have tried different inputs with gyro but it all has the same issue. This wasn’t an issue a while ago and I am confused why it would be one now but I guess the newest version has some kinda bug.

I am using a steam deck and the version of Citra is Citra Nightly 1940

Diagnostic Log
citra_log.txt (6.4 KB)
citra_log.txt.old.txt (18.4 KB)

I don’t recall us having touched sdl or gyro stuff at all lately. Do you have some clue as to how long ago this worked fine for you?

From December until February I think, it was working fine. I didn’t play the game for a bit but I updated Citra about a month ago and thought to get back into the game and this bug has been stopping my progress.

Did you use emudeck in the past, or are you using that now?

Been using emudeck the whole time.

Update to testing stuff out. I am an idiot and the gyro doesn’t work in practice either. I was stupid and didn’t realize the demo wasn’t me actually making inputs but either way I tried out the mouse way for tilting and that worked but the regular gyro doesn’t work still so I am not sure if this is an emudeck issue or citra cause it did work once in the past.