DS4 not working with latest build

I’m able to setup the buttons in citra with a DS4, but pressing buttons in-game doesn’t do anything. I can’t get passed the “press A to continue” screens in metroid samus returns and mario 3d land.

System Information

  • Operating System: macOS 12.6
  • SYSTEM: 2015 15" macbook pro. Intel i7 whatever, M370X
  • Citra Version (found in title bar): Nightly 775fb38
  • Game: Samus Returns, Mario 3D land.

Can you show your input window? It should be located in Emulation - Configure - Input


What happens if you try setting it up again? Citra is fully controller compatible, so if you press on a box to change the input, you can press a key on the controller directly.

Dualshock 4 is broken in configuration box from what I understand. You can try editing the qt-config.ini file with this guide. Not guaranteed to work.

I don’t get how you guys claim Citra is fully controller compatible but the DS4 doesn’t work. Is it just the DS4? Why doesn’t it work? Any word on time frame for fix? Thanks.

There is a bug with the DS4 controllers only.

“When polling for input, Citra will check to see if you moved a joystick (called an axis) and it does that by checking to see if its greater than half of the range of motion
the problem is the DS4 has two joysticks, but also two analog triggers, l2 and r2
and those analog triggers range from -max to +max
so in resting state, citra sees it as “fully pressed””

We can’t say for certain when it will be fixed, but a dev is working on a fix right now.

Thanks for confirming, i thought it was just me :stuck_out_tongue:

weird, i just set mine up, like 30 mins ago, and they are working fine

ds4 controllers work. just due to a stupid issue with how ds4windows works, it maps the controller resting state to s16 min instead of 0 like every other controller does. You can manually add the controllers to citras settings and it’ll work just fine, or just wait for the controller changes that i’m working on. trust me, the ds4 controller will soon be the best controller for citra before you know it.

Ah! I did noticed when i first plugged it in, it was acting weird between the D pad and the joystick controls, but i manually set the keys, and it worked.

Hope you finish that control plug in, is so much better to play citra with a controller.

How could something that never worked stop working?

Exactly… besides, if you read the OP, I was talking about the mac version. On a mac you plug in a ds4 and the OS recognizes it. But for whatever reason doesn’t work in citra.