Dunno which latest version(s) of Citra(s) requiere minimum opengl specific version?

Issue:
I need to know which latest version of citra & citra-canary needs a specific version of OpenGL ?

System Information

  • Operating System: Windows 7 (64 Bits)
  • CPU: Intel Core i3-3220
  • GPU: Intel HD
  • Citra Version (1270):
  • Game: Various
  • Screenshot of Issue (include the full Citra window including titlebar): This is not useful for the information i need.

Diagnostic Log
i don’t have a diagnotic tools for this

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I need to know which latest version of citra & citra-canary needs a specific version of OpenGL ?
Which latest version of Citra and/or Citra-Canary needs minimun OpenGL 4.5 ?
Which latest version of Citra and/or Citra-Canary needs minimun OpenGL 4.4 ?
Which latest version of Citra and/or Citra-Canary needs minimun OpenGL 4.3 ?
Which latest version of Citra and/or Citra-Canary needs minimun OpenGL 4.2 ?
Which latest version of Citra and/or Citra-Canary needs minimun OpenGL 4.1 ?

Which latest version of Citra and/or Citra-Canary needs minimun OpenGL 4.0 ? (i had support until this opengl version)

Which latest version of Citra and/or Citra-Canary needs minimun OpenGL 3.3 ?
Which latest version of Citra and/or Citra-Canary needs minimun OpenGL 3.0 ?

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

Citra Nightly 1782: OpenGL 3.3
Citra Nightly 1793+: OpenGL 4.3

If you don’t have a dedicated GPU installed, you’ll need to use Nightly 1782:
Release nightly-1782 · citra-emu/citra-nightly · GitHub
Download citra-windows-mingw-20220901-d380980.7z , extract the file and open citra-qt(.exe).

You may also need to disable V-Sync in Emulation>Configuration>Graphics>Advanced tab.

1 Like

Thank you for your answer, the pc i specify there, is from friend, he just had Integrated graphics, my pc is more old but i had GPU Nvidia GT 620 GT ah support until OpenGL 4.6.0

Which are the main diferences beetween Citra & Canary ?

The nightly build of Citra contains already reviewed and tested features. If you require support with the installation or use of Citra, or you want to report bugs you should use this version.
The Canary build of Citra is the same as our nightly builds, with additional features that are still waiting on review before making it into the official Citra builds. We will not provide support for issues found only in this version. If you believe you’ve found a bug, please retest on our nightly builds. Both versions are still in development, so expect crashes and bugs.

Since you’re asking about what is basically legacy support, Nightly builds are more appropriate.

1 Like

Thank you very much for you answer.

Yes a Legacy version i am looking for specific latest version of citra needs OpenGL 4.0 like minimun req.