Emulation speed increase functionality no longer works properly


#1

Issue:
As of about 5 days ago on Citra Canary, the ability to increase emulation speed (mapped to Ctrl + Z) no longer speeds up the game. I have tried using the + key to bring up the speed, and while it increases the number on the right side of the slash like so: https://i.imgur.com/Hcy2PJX.png, it does not increase the speed at all.

Furthermore, as of roughly 5 days ago, the option to map this to the controller has also disappeared. Before this occurred, there was a Hotkeys tab to the right of the Input tab. Now, the only way to see the option is in the Hotkeys subsection of the General tab, where the hotkey cannot be changed at all.

This functionality was 100% functional with all of the same specs and the same game posted below, so I do not know what has changed.

Any help fixing this would be appreciated.

System Information

  • Operating System: Windows 10 Home
  • CPU: Intel i5-8300H
  • GPU: Nvidia GeForce GTX 1050
  • Citra Version (found in title bar): Citra Canary 937
  • Game: Dragon Quest Monsters - Joker 3 (JP) (english patch)

Log: citra_log.txt (4.0 KB)


#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.


#3

Can you triage this down to to the breaking version, by manually them?


#4

Of course! I’ve tracked down the issue to Canary build 906. Everything 905 and below seems to have the Hotkeys tab, but nothing past 906.

Edit: The speedup option on builds 905 and below seem to work for roughly 30 seconds before reverting back to normal speed and refusing to go back up, despite re-attempting Ctrl + Z and even restarting the computer.


#5

In further testing, I have found a stranger bug - the game can speed up, but only when the Citra window is out of focus. It also depends entirely on what I set the Limit Speed Percent to - turning it off or setting it to a number above 100% will speed it up, but pressing Ctrl + Z does not influence this at all. It seems to be speeding up when out of focus no matter if Toggle Speed Limit is actually toggled or not. This issue is persistent on both Canary 937 and 905.


#6

Starting with Canary version 906, this pull request was no longer merged. When the conflicts are fixed, this will be added back to Canary.

I would make a new issue for this.


#7

I’ve fixed those conflicts already. It needs to be reviewed, specially by @B3n30 as I made some major changes to the code he wrote.
EDIT: There are some build issues with it, so it can’t be added back rn.