Emulator Crash After Alpha Sapphire Language Select

After language select in Pokemon Alpha Sapphire, the whole game crashes. I haven’t played Citra in a while, so when I reinstalled it, the whole thing crashes with Alpha Sapphire. I’ve never had this problem before.

System Information

  • Operating System: Windows 10
  • CPU: Intel(R) Core™ i7-6500U
  • GPU: Intel(R) HD Graphics 520
  • Citra Version (found in title bar): Citra Nightly 1809
  • Game: Pokemon Alpha Sapphire

Diagnostic Log
citra_log.txt (21.3 KB)

System Information for Support

Client Version                               Nightly 1809   HEAD-94d0399
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            Intel(R) HD Graphics 520
GPU Driver Version                           23.20.16.4973
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [ ]
System Region                                -1
Shader Disk Cache                            [ ]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Update, my GPUs are up to date, just an older computer that shouldn’t be having this problem. I also enabled accurate multiplication.

citra_log.txt (21.4 KB)

System Information for Support

Client Version                               Nightly 1809   HEAD-94d0399
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            Intel(R) HD Graphics 520
GPU Driver Version                           23.20.16.4973
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [ ]
System Region                                -1
Shader Disk Cache                            [ ]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics

This driver is still very out of date (2018). To update, download win64_25.20.100.6373.zip from Legacy Intel® Graphics Driver for Windows® 10
Mirror download: https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip

Then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Now you should be able to install the latest DCH drivers directly:
Download and install gfx_win_101.3790_101.2114.exe from Intel® Graphics – Windows* DCH Drivers
Mirror download: https://downloadmirror.intel.com/751359/gfx_win_101.3790_101.2114.exe

Let me know if Windows decides to revert your driver again after this (yes, Windows does that sometimes for some reason).