Enabling "Enable Hardware Shaders" Leaves Slow Emulation

Issue:
When you enable the option “Enable hardware shaders” instead of increasing the emulation speed, it drops a lot, going from 25fps to 12fps, even in the emulator saying it would increase the speed.

System Information

Diagnostic Log
citra_log.txt (9.3 KB)

System Information for Support

Client Version                                Canary 1345 HEAD-c8ff1da
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [ ]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
1 Like

The AMD OpenGL drivers are inefficient/buggy. these sort of performance issues are to be expected.