Enabling Hardware Shader results in black screen

Issue:
Whenever I enable the hardware shader, games stop rendering and instead display a black screen. This happens in both The Legend of Zelda Ocarina of Time 3D, and Fire Emblem Awakening. In awakening, at one part of the title screen some particle effects are visible, but that is all that renders. Audio plays at full speed in the background. With the hardware shader off, things render properly.

System Information

  • Operating System: Ubuntu 17.10
  • CPU: i7-4770k
  • GPU: GTX 970
  • Citra Version (found in title bar): I had to compile citra myself following the guide for compiling on Ubuntu 16.04, as the linux builds don’t run on 17.10 due to an outdated version of glibc, compiled from the commit labelled Canary #585.
  • Game: Fire Emblem Awakening, Legend of Zelda Ocarina of Time 3D
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (60.2 KB)

1 Like

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I also tried with a freshly compiled version of citra from the main repo, using commit #3876. I got the same result. In addition, this occurred in Pokemon Sun as well with both versions of citra.

To anyone reading this with the same issue on linux, try rolling back your GPU driver. I was on nvidia-396 (latest proprietary driver), and rolled back to nvidia-390. Hardware shaders work now.

2 Likes

disable your hardware shader, so it can run more smoothly

The hardware shader option speeds things up actually. Unless your GPU can’t use it without having graphical glitches, it should be enabled.