Enabling "Hardware Shader" Turns my entire screen black

Issue:
As the title suggests, i can play every game fine, but if i activate “Hardware Shader” the screen freezes for 1-2 seconds then goes black but i can still hear the sound just fine the reason i am turning it on though is because the game i am currently playing Fire emblem Fates Special edition is giving me alot of graphic errors, now that alone wouldn’t be a big problem but its getting worse the more i get into it and new errors each pop up when i launch the game. The graphic glitches disappear when i disable “Hardware Renderer” but the game just slows tf down.


System Information

  • Operating System: Windows 7
  • CPU: Intel® Core™ i3-2120 CPU @3.30 Ghz 3.30 GHz
  • GPU: ATI Radeon HD 4600 Series
  • Citra Version: Nightly 1244
  • Game: Fire Emblem Fates Special edition
  • Screenshot of Issue (inc:

Diagnostic Log

<citra_log.txt (90.9 KB)

System Information for Support

Client Version                                Nightly 1244 HEAD-e9c2b27
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               ATI Radeon HD 4600 Series
OpenGL Version                                3.3.1
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Older AMD GPUs are known to have graphical issues, I would keep hardware shaders off and hardware renderer on. Otherwise there’s not much you can do besides make sure you have the latest graphics drivers.